View Issue Details

IDProjectCategoryView StatusLast Update
0014037MediaMonkey (current)Playerpublic2017-02-24 18:47
Reporterrusty 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1.15 
Target Version4.1.15Fixed in Version4.1.15 
Summary0014037: Playback fails with Jammix enhancer plugin - permissions problem (regression)
DescriptionIf the user enables the Jammix enhancer plugin during playback
--> playback stops and for each subsequent track the seekbar cycles through the track in about 10s silently and then goes to the next track and does the same thing. The only way to stop this is by disabling the plugin.

On the other hand, if the user enables the plugin and _then_ starts playback, it seems to work correctly.

The is a regression in 4.1.15--I've verified that it does not occur with MMW 4.1.14.1813.

Debug log posted to the ftp server. Up until about line 6000, playback was working normally as I played/skipped tracks. At line 6000, I disable/re-enabled the plugin and from that point onwards the problem occurred.

Tested with Windows 10 using the default MM Directsound output plugin.

Note: I've set this as 'immediate' because although Jammix is probably used only by a small percentage of users, the regression is probably symptomatic of other playback issues.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=7&t=87200
TagsNo tags attached.
Fixed in build1829

Relationships

child of 0014038 closedpetr MediaMonkey may lose config settings / fails to run (regression) 

Activities

peke

2017-02-24 00:39

developer   ~0047345

Actually all DSP Plugins can fail to initialize and fetch Audio Data Correctly.

Most common is also EDCast(IceCast) http://www.happymonkeying.com/plugin.php?q=300088 that worked previously.

To Check Correct Audio Data is sent (unless you want to setup icecast server) you need to click on peak control in plugin settings so that you see Audio level Which gets hammered to max and is gibberish not audio.

peke

2017-02-24 13:11

developer   ~0047348

As found WASAPI make issues with DSP plugins (That is longstanding issue), but MMDS works as expected.

Tested on various file types and formats

16/24 Bits
2/5.1 Channels
44.1/48/96 Sample rate

rusty

2017-02-24 14:24

administrator   ~0047350

I retested (using only local files), and the failure still occurs :-(

The really interesting thing though is that it doesn't occur on a clean_portable install of 1829. It only occurs on the 'normal' (to C:/Program Files...) install of MM (that had been upgraded from 4.1.14 and the various 4.1.15 beta builds).

rusty

2017-02-24 15:20

administrator   ~0047351

Confirmed with Michal:

With MM 4.1.14 (non-portable install), Jammix plugin works as expected.
Upgrade to MM 4.1.15, Jammix plugin fails.

It's related to the fact that the plugin seems to require certain config information and with MM 4.1.14 the information is saved to C:\Users\Michal\AppData\Local\VirtualStore\Program Files (x86)\MediaMonkey\WinAmp.ini , however 4.1.15 doesn't save to that location and instead ends up using a 0B Winamp.ini file (generated by?) in the Program Files/MediaMonkey directory.

petr

2017-02-24 15:51

developer   ~0047352

Fixed

rusty

2017-02-24 18:47

administrator   ~0047355

Verified 1830.