View Issue Details

IDProjectCategoryView StatusLast Update
0013882MediaMonkey (current)Synchronizationpublic2017-01-09 18:12
ReporterLudek 
PriorityimmediateSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version4.1.14 
Target Version4.1.15Fixed in Version4.1.15 
Summary0013882: iOS10 sync can fail when there is already 15.000 tracks on the device
DescriptionBased on the log from ticket FHG-652-93864 the sync is getting slower with amount of the tracks already on the device.

If there is already 15.000 tracks then we need to wait almost 30 seconds for the device to reply with the "AssetManifest" message.
And because our timeout is 30 seconds it fails near after that.
Also we "commit" the copied tracks every 40 seconds or once 50 tracks were uploaded (batch of 50 tracks), but also the copy operation becomes slower (when there is already 15K of tracks) and thus only 20 tracks are copied during 40 seconds + 30 seconds waiting for the "AssetManifest" message.

The timeouts needs to be prolonged and the commit batches adjusted to accomplish this.
Additional InformationFHG-652-93864
QBV-910-45672
TagsNo tags attached.
Fixed in build1822

Relationships

related to 0013883 closedLudek iOS sync cannot be terminated in some cases 
related to 0012362 resolvedLudek Apple Device sync: Synchronization is progressively slowing down as during sync 

Activities

Ludek

2017-01-06 15:58

developer   ~0046865

Last edited: 2017-01-09 18:12

View 2 revisions

Fixed in 4.1.15.1822 and merged to 5.0.0.2058