View Issue Details

IDProjectCategoryView StatusLast Update
0013861MediaMonkey 5Taggingpublic2017-01-16 02:26
ReporterLudek 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0013861: Crash after Auto-Tag from Web
DescriptionThere is a crash after using Auto-tag from a web on an album.

I see the crash too.
Must be a recent regression related to 0013678.

Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=30&t=86752
Log ID 4118D8C3
TagsNo tags attached.
Fixed in build2058

Relationships

child of 0013678 closedpetr Add artwork dialog is missing (can't apply artwork to all tracks on an album, or label an image) 

Activities

Ludek

2017-01-02 16:29

developer   ~0046821

It was caused by Petr by adding this line:

uitools.editCoverProperties(origTrack, cover, true);

to dlgAutoTagFromWeb.js in course of 0013678

I commented the line and see several issues before adding it back:

1) This way the add artwork dialog would be shown for _each_ track. It should be shown only once for whole the album (as in MM4)
2) There is a leak in the uitools.editCoverProperties because of usage of track.keepCoverList = true. It should be replaced by keeping the reference to the track.coverList and null the reference in the resolver of editCoverProperties .

Ludek

2017-01-02 16:31

developer   ~0046823

Resolved and tracked in the original issue: 0013678:0046822

peke

2017-01-16 02:26

developer   ~0046968

Verified 2058