View Issue Details

IDProjectCategoryView StatusLast Update
0013717MediaMonkey for AndroidUPnP / Castingpublic2016-12-06 15:23
Reporterpeke 
PrioritynoneSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version1.2.0Fixed in Version 
Summary0013717: Playback Controls do not work
Descriptiona) When casting to MMW then
1. Next command acts like repeat track eg. tracks after delay starts again
2. Prev is not executed at all

Note: Play/Pause and Stop Work
TagsNo tags attached.
Fixed in build

Relationships

duplicate of 0013718 feedbackpeke MediaMonkey 5 Casting: MMW Now playing behavior when MMW is renderer 

Activities

peke

2016-12-05 22:45

developer   ~0046401

Reassigned to me as it looks like it is more like MMW issue than MMA

rusty

2016-12-05 23:05

administrator   ~0046402

Last edited: 2016-12-05 23:05

View 2 revisions

Note: I can't replicate when casting via UPnP (to Kodi) or Chromecast.

peke

2016-12-05 23:44

developer   ~0046406

Assign due the possible close relation to 0013718

Also I noticed that when MMW is used as renderer MMA rarely play next track in now playing but acts as repeat single.

Ludek

2016-12-06 14:01

developer   ~0046411

Last edited: 2016-12-06 14:57

View 3 revisions

Peke, I cannot replicate (tested MMA 1.2.0.620 + MMW 4.1.15.1818).

But it could be a timing issue or something like that.

Could you please:
1) Verify that it doesn't work MMA 1.2.0.620 + MMW 4.1.15.1818
2) Ensure that it is not a test error and clearly describe what isn't working (I suppose you are using Next/Prev in MMA)
3) Generate debug log

Ludek

2016-12-06 15:08

developer   ~0046414

Last edited: 2016-12-06 15:14

View 4 revisions

As clarified over IM:

Peke meant pressing Next/Prev in MMW (when MMW acts as renderer) while MMA is the control point.

In that case we should probably just disable the Next/Prev buttons in MMW.

i.e. It is not possible in UPnP/DLNA standards for the renderer to control the NP queue. MMW would need to act as control point (it is acting as renderer)

Anyhow testing some renderers (e.g. foobar) and when playing to foobar the prev/next are also enabled although doesn't work right.

Ludek

2016-12-06 15:23

developer   ~0046416

Closing as it looks like duplicate of 0013718