View Issue Details

IDProjectCategoryView StatusLast Update
0013548MediaMonkey for AndroidSynchronizationpublic2019-09-12 01:40
ReporterLudek 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version2.0.0Fixed in Version2.0.0 
Summary0013548: Genre changed in MMA isn't synced to MMW
Description1) Create a playlist with Track1, add the playlist to sync list and WiFi sync to MMA
2) Change rating and genre of the track in MMA
3) Perform Wi-Fi sync

=> rating is updated in MMW, but genre isn't !

I guess this must be a regression because MMW is accepting genre field modifications. Currently accepted fields are: 'playcount', 'skipcount', 'last_time_played', 'bookmark', 'title', 'album', 'artists', 'album_artist', 'composers', 'genres', 'lyrics', 'track', 'year', 'type', 'rating'
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=7&t=85759
ZCG-606-39652, GAV-956-79438
TagsNo tags attached.
Fixed in build800

Relationships

related to 0011794 newmartin Scanning engine / tag parser / tagging engine 
related to 0014267 newmartin Bi-Directional sync for CD# / Track # 
related to 0014340 newmartin Play history is incomplete / not fully synced 

Activities

marek

2016-10-14 09:13

developer   ~0045933

Last edited: 2016-10-19 12:00

View 3 revisions

It is not regression, following fields were never synced to MMW:
'artists', 'composers', 'genres', 'track'

I suggest to postpone it to 1.2.1 because multi-value modifications were not implemented yet and it should be well tested.

rusty

2016-11-03 21:04

administrator   ~0046090

OK. As a general rule, users would expect that any field that appears in MMA is synced.

martin

2017-04-04 08:56

developer   ~0047716

Fixed in build 2.0.0.800