View Issue Details

IDProjectCategoryView StatusLast Update
0013303MediaMonkey for AndroidUPnP / Castingpublic2016-09-01 02:14
Reportermarek 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.0 
Target Version1.2.0Fixed in Version1.2.0 
Summary0013303: UPnP is not working on Android N
DescriptionDue to migration of Android N to OpenJDK, Cling UPnP library stopped working.

Tracked in Cling bug tracker as:
https://github.com/4thline/cling/issues/164

It is due to workaround that use reflection and doesn't work due to changes in class structure.
Related thread:
http://4thline.org/projects/mailinglists.html#nabble-td3011461
Additional InformationReported at: http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=84835
Ticket with logs: BLK-104-82190
Fix confirmed in 614 topic http://www.mediamonkey.com/forum/viewtopic.php?f=26&t=85836
TagsNo tags attached.
Fixed in build612

Activities

marek

2016-05-23 19:45

developer   ~0044707

It is possible to override the functionality and replace the code it easily. But I still don't have working fix. Test code committed.

marek

2016-07-15 07:26

developer   ~0045161

Last edited: 2016-08-24 10:57

View 2 revisions

Fixed in build 1.2.0.612

peke

2016-08-25 21:40

developer   ~0045496

Verified 612