View Issue Details

IDProjectCategoryView StatusLast Update
0013248MediaMonkey for Android[All Projects] Generalpublic2016-11-11 18:05
Reporterpeke 
PriorityurgentSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version1.1.3 
Target Version1.3.0Fixed in Version1.2.0 
Summary0013248: Menu Button doesn't appear on some devices
DescriptionThere is some phone manufacturers that allow customization of software buttons to MMA detects that menu button is available and omits showing it on MMA screen.

It could be useful to add "Always show menu button in options" or add options to MMA home screen in cases like these

One of devices that is known to have customization of buttons is https://oneplus.net/x
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=26&t=84528
PEW-540-51470
FVN-718-70128
OIS-846-76740
TagsNo tags attached.
Fixed in build619

Activities

marek

2016-05-23 20:59

developer   ~0044709

I think that we should add the button for all devices 5.0+. The standard navigation bar layout doesn't include MENU button any more and new MMA UI will not hide the menu too.

It is also weird to put visibility of MENU to MENU - because it become inaccessible when user disables it.

I also suggest to include it to 1.2.0 or 1.2.1 as it is simple and might be quite annoying on some devices...2.0 will use different design.

rusty

2016-05-23 21:54

administrator   ~0044710

Last edited: 2016-05-23 21:55

View 3 revisions

Considering that the problem already occurs on 2 devices, we should include this in 1.2.0. I agree with Marek that no settings are required.

marek

2016-05-24 19:42

developer   ~0044735

So I was wrong. Material design can work with MENU button too.

I have found out that it is a known bug only on OnePlus devices. So we can workaround it and show it always only on OnePlus devices. Otherwise, there is system function that should work fine for other devices.

Btw. long press of WINDOW button behaves like old MENU button too. But in this case: the three dots icon has to be displayed. This icon is hidden only if PERMANENT MENU BUTTON is available.

I asked for log so we can identify the OnePlus devices and show the menu.

rusty

2016-06-15 14:36

administrator   ~0044953

Apparently this issue affects some other devices as well e.g. Polaroid A4.
Report at: FVN-718-70128

This complicates things because it means that there we'd have to identify every device that has this problem. Unfortunately, Peke's original idea of:
 [ ] Always show menu button

probably wouldn't work, because the user wouldn't have access to the menu in order to enable it!

marek

2016-06-16 12:34

developer   ~0044955

It is fixed in build 605 for OnePlus devices

But it us really hard to fix it when it depends on system function that is not reliable for some devices.

Btw we use this method: https://developer.android.com/reference/android/view/ViewConfiguration.html#hasPermanentMenuKey()

marek

2016-06-16 13:07

developer   ~0044956

I have created a special build for the user and asked him for the log

marek

2016-06-17 10:00

developer   ~0044960

Last edited: 2016-06-17 10:01

View 2 revisions

Fixed in build 605

Added workaround for Polaroid devices

peke

2016-06-17 21:52

developer   ~0044973

Last edited: 2016-06-17 21:52

View 2 revisions

To make things easier to access things like these I was wondering if we could add ABOUT dialog to TAP on MMA Icon on Main Screen.

That would also speed up log sending?

peke

2016-06-28 23:42

developer   ~0045058

Verified 607

peke

2016-07-05 20:55

developer   ~0045089

Additional report on Alcatel Pixi 4 with latest firmware

http://www.mediamonkey.com/forum/viewtopic.php?f=26&t=85459&p=425223#p425223

rusty

2016-08-30 18:57

administrator   ~0045520

Similar request for the Meizu M2 Note:
VUD-591-50422

peke

2016-10-14 00:08

developer   ~0045929

New report on Axon 7 Device
http://www.mediamonkey.com/forum/viewtopic.php?p=428138#p428138

lowlander

2016-10-26 14:40

developer   ~0046029

New report on Meizu M3S
OIS-846-76740

marek

2016-10-31 09:35

developer   ~0046059

Fixed in build 619

There are so many devices with this issue.. so I decided to show the menu button always....

peke

2016-11-11 18:05

developer   ~0046135

Verified 620