View Issue Details

IDProjectCategoryView StatusLast Update
0013238MediaMonkey (current)Synchronizationpublic2016-05-24 00:36
Reporterpeke 
PriorityurgentSeveritycrashReproducibilitysometimes
Status closedResolutionfixed 
Product Version 
Target Version4.1.12Fixed in Version4.1.12 
Summary0013238: Device removal: MMW can crash on USB cable disconnect
DescriptionSometimes if usb is removed when MMW tree is focused on Device profile can result in crash.

TagsNo tags attached.
Fixed in build1796

Activities

peke

2016-04-20 23:53

developer  

Moto G Removal.rar (13,382 bytes)

Ludek

2016-04-21 11:17

developer   ~0044477

Fixed in 1788

peke

2016-04-26 21:38

developer   ~0044503

Verified 1789

Ludek

2016-05-12 15:20

developer   ~0044599

Re-opened,
Rusty still observes crash on disconnect with "Amazon Fire HD" device. ELF submitted.

Ludek

2016-05-12 15:25

developer   ~0044600

Fixed in 1792.

peke

2016-05-14 21:52

developer   ~0044618

Verified 1793 Moto G

Ludek

2016-05-23 18:51

developer   ~0044706

Last edited: 2016-05-23 18:58

View 2 revisions

Re-opened: As found by Marek (and also reproducible by me now) there is a regression, USB sync now freezes when USB cable is disconnected during file copying. Not sure why I didn't observe this while fixing and why Peke haven't found this while veryfing, but seems to be consistently reproducible for me now.

Fixed in 1796.

peke

2016-05-24 00:36

developer   ~0044715

You were right about teh reason I was not detecting it

Verified 1796