View Issue Details

IDProjectCategoryView StatusLast Update
0013146MediaMonkey (current)DB/FileMonitorpublic2016-03-01 18:40
Reporterpeke Assigned To 
PriorityurgentSeveritymajorReproducibilityunable to reproduce
Status closedResolutionfixed 
Product Version4.0.7 
Target Version4.1.12Fixed in Version4.1.12 
Summary0013146: Library re-scan can produce double Podcasts entries in some cases
DescriptionIn some cases MM.DB contains double podcast episode entries for the same library file.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=7&t=83771
XHF-418-63153
TagsNo tags attached.
Fixed in build1785

Activities

Ludek

2016-02-23 12:07

developer   ~0044195

Last edited: 2016-02-23 12:48

View 4 revisions

Analyzed user's database and the duplicities are in the PodcastEpisodes relation table between Songs and Podcasts. i.e. the tracks are in library only once, but have double entries in the PodcastEpisodes table.

It was caused during library scans, user most probably previously removed the episodes from DB and the tracks were re-scanned and associated to the correspond feeds.

Looking into the code it can really produce duplicates during auto-scans (file monitor), because the SQL is in transaction and another scanning thread could do the same at the same time.

So I would rather fix the cause (not the consequence) -- renaming the issue.

Ludek

2016-02-23 12:30

developer   ~0044196

Last edited: 2016-02-23 13:07

View 2 revisions

Fixed in 4.1.12.1785


To fix the consequence (double entries):
1) Install build 4.1.12.1785
2) Select the affected files and delete them from Library Only
3) Re-scan them to library

Ludek

2016-03-01 18:40

developer   ~0044219

Confirmed via XHF-418-63153