View Issue Details

IDProjectCategoryView StatusLast Update
0013095MediaMonkey for AndroidPlaybackpublic2016-02-14 20:01
Reportermartin Assigned To 
PriorityurgentSeveritymajorReproducibilityhave not tried
Status closedResolutionno change required 
Target Version1.1.3Fixed in Version1.1.3 
Summary0013095: Local player playback fails on tracks from sdcard on Marshmallow devices (xperia Z3 / LG 64)
Descriptionhttp://www.mediamonkey.com/forum/viewtopic.php?f=26&t=83804

From the log media player throws error :
onError: 1, extra:-2147483648
It means MEDIA_ERROR_UNKNOWN
https://developer.android.com/intl/ru/reference/android/media/MediaPlayer.html#MEDIA_ERROR_UNKNOWN

I think that cause of this error is path to files on sdcard:
/storage/public:179,65/Music/Air/Moon Safari/01 Air - La Femme d'Argent.mp3

the name of sdcard "public:179,65" is quite weird and I guess that MediaPlayer can have issue with that.


The log file:
https://rink.hockeyapp.net/manage/apps/66872/app_versions/116/crash_reasons/107240652
TagsNo tags attached.
Fixed in build

Relationships

related to 0013063 resolvedmarek LG L-65: Storage prefixes for SD card don't match 

Activities

martin

2016-01-28 15:49

developer   ~0044012

Last edited: 2016-01-28 16:01

View 2 revisions

New Developer option "Use alternative uri" in build 1.1.3.537
Tested on emulator. When this option is enabled,
our media player use path:
/sdcard/Music/song.mp3
instead
/storage/1BE5-3605/Music/song.mp3

in my case both urls works. We will see what happens on Z3.

marek

2016-01-30 09:47

developer   ~0044028

Last edited: 2016-01-30 09:51

View 2 revisions

There were some issues in debug log so we don't see the tree structure of storages. It is fixed in build 536.

I think that it shoudn't be fixed in player. We have to parse valid path in StorageScanner.

In your case, /storage/1BE5-3605/ is valid path, it uses storage GUID and it works on many devices. But I have never seen the path with /public:179,65/. We will see the diagnistotics in build 538.

Btw we can also use SAF uri for playback. This can be generated from path.

rusty

2016-02-04 14:46

administrator   ~0044063

Report of this on the G4:
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=83916

marek

2016-02-04 16:17

developer   ~0044066

Last edited: 2016-02-04 16:59

View 3 revisions

new crashlog:
https://rink.hockeyapp.net/manage/apps/64672/app_versions/344/crash_reasons/109923814

marek

2016-02-08 18:42

developer   ~0044083

I have found out that the user uses Marshmallow Concept ROM. So it is not final version. This bug is probably caused by invalid path that is incorrectly generated by system.

Marshmallow contains new system command line app for storage management. By running "sm list-volumes" we can obtain all storages.

Sample list from LG G4:
<code>private mounted null
public:179,65 mounted 9F29-15FD
emulated mounted null</code>

G4 and all other Marshmallow devices have the path to external storage ''/storage/9F29-15FD'' which is correct and ''9F29-15FD'' is UID of storage.

But Z3 Concept rom mounts it as ''/storage/public:179,65'' so it looks like bug in ROM. I think that we shouldn't repair it now and wait for release version of Z3 ROM.

peke

2016-02-14 19:54

developer   ~0044155

User is confirming that it works now http://www.mediamonkey.com/forum/viewtopic.php?p=420031#p420031