View Issue Details

IDProjectCategoryView StatusLast Update
0013048MediaMonkey (current)Synchronizationpublic2017-03-07 17:02
ReporterLudek 
PriorityurgentSeveritymajorReproducibilityunable to reproduce
Status closedResolutionfixed 
Product Version4.0.7 
Target Version4.1.11Fixed in Version4.1.11 
Summary0013048: iPod Video: sync fails when there is more than 30.000 songs with artworks on the iPod
DescriptionUser from ticket JCB-488-19898 is observing sync failure for iPod Video including 30.000 songs. First sync gone fine, but further sync crashes.

MediaMonkey fails to read device artwork database (because of artwork thumb offset overflow to negative value)
Additional Informationhttps://support.apple.com/kb/sp41?locale=cs_CZ
JCB-488-19898
TagsNo tags attached.
Fixed in build1779

Relationships

related to 0014079 resolvedLudek iPod Video 5G models shows artwork only for the first track on an album 

Activities

Ludek

2016-01-05 12:56

developer   ~0043791

Last edited: 2016-01-05 13:23

View 4 revisions

Reason is that artwork thumb chunk for 200x200 px is 80000.
80.000 * 30.000 songs = 2.400.000.000 which is roughly the upper limit for MHNI.offset (that is integer) and thus overflows to negative value.

This causes artwork not showning correctly in iPod, and also MM fails to scan or sync it (because of the unexpected negative offset value).

Ludek

2016-01-05 13:21

developer   ~0043792

Fixed in 4.1.11.1779

peke

2016-01-24 07:32

developer   ~0043962

Verified 1780 on iPod Touch 4G No regression