View Issue Details

IDProjectCategoryView StatusLast Update
0013005MediaMonkey 4Synchronizationpublic2016-02-10 11:32
Reporterpeke Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1.10 
Target Version4.1.10Fixed in Version4.1.10 
Summary0013005: MWM Create double Profile each MMW Start (when info file cannot be written)
DescriptionMost likely due the bug 0012999 on Start MMW create new profile for Internal Storage.

It happen to me few times, but it is not consistent.
TagsNo tags attached.
Fixed in build1775

Relationships

related to 0012999 closedmarek MediaMonkey for Android MediaMonkey/files/ directory is presented as file over MTP (regression?) 
related to 0012997 closedLudek MediaMonkey 4 USB Sync do not get correct Storage names 
related to 0013119 closedLudek MediaMonkey 4 Duplicate profiles can occur due to deletion of storageInfo.xml 

Activities

peke

2015-12-08 14:16

developer  

duplicates.jpg (108,430 bytes)   
duplicates.jpg (108,430 bytes)   

Ludek

2015-12-08 14:53

developer   ~0043546

Last edited: 2015-12-08 14:54

View 2 revisions

Peke, I guess that they are created _everytime_ when you manually deleted storageInfo.xml, right? It is because 0012997:0043512

But it is all right, the reasons are that single SD card can be put to various Android devices or SD card slots and there isn't any other way how to pair a storage with a profile without this info file.

peke

2015-12-08 16:33

developer   ~0043554

Last edited: 2015-12-08 16:36

View 2 revisions

I do not have issues with SD card but with Internal Storage where "files" is file not folder and MMW can't read StorageInfo.xml

In 0012961 I always start with Clean MMW/MMA installs where there is no profiles at all so once storageinfo/xml is created which it can't be created due the 0012999 it should be read each time and not try to creat new one on each start.

Ludek

2015-12-08 16:48

developer   ~0043556

OK, so it is consequence of 0012999 where MMW cannot write the StorageInfo.xml.mmw because the 'files' is presented as file and not folder.

The true is that the newly generated GUID shouldn't be assigned to a profile until the StorageInfo.xml.mmw is successfully uploaded.

Ludek

2015-12-08 17:11

developer   ~0043557

Fixed in 4.1.10.1775

peke

2015-12-08 17:32

developer   ~0043559

My guess that StorageInfo.xml.mmw is updated by MMA but MWM can't read it so it create new one and loop is created.

Will test in 1775

rusty

2015-12-11 04:11

administrator   ~0043599

I had observed this in prior builds but not in 1775. Leaving for Peke to verify/close.

peke

2015-12-11 16:18

developer   ~0043612

verified 1776

Just to ensure bug was still present in 1774

rusty

2015-12-15 06:38

administrator   ~0043662

I'm seeing this in 1778 (testing with Asus Zenfone 2 / lollipop running MMA 522)
1 run MMA and close
2 usb sync
3 wi-fi sync (successfully uses the previously created profile)
4 connect usb cable and attempt to view/configure sync settings
--> it is using a brand new blank profile instead of the profile from step 2!!
may be related to 0012999 (though I don't understand why Wi-Fi sync (step 3) successfully used the profile but not usb-sync (step 4).

marek

2015-12-15 11:29

developer   ~0043669

Fixed in MMA build 523

rusty

2015-12-15 21:33

administrator   ~0043675

Verified 523 / 1778