View Issue Details

IDProjectCategoryView StatusLast Update
0012981MediaMonkey 4Synchronizationpublic2015-12-12 01:48
Reporterrusty Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version4.1.9 
Target Version4.1.10Fixed in Version4.1.10 
Summary0012981: Crash on disconnect of USB cable
Description1 Connect device over usb
2 Click the device to view its profile
3 Remove a playlist from the auto-sync list
4 Auto-sync
-->Auto-sync delete confirmation dialog appears
5 Disconnect the device
-->MMW crashes

Note: over the course of testing the past few days, I've submitted quite a number of crashes that seem to be related to USB sync, but this scenario consistently triggers a crash and I suspect that it's related to the others.

Crash log indicates the bug number.
TagsNo tags attached.
Fixed in build1775

Relationships

related to 0012961 resolvedpeke USB Sync freezes when removing content 

Activities

Ludek

2015-11-27 17:16

developer   ~0043434

Fixed in 4.1.10.1770

rusty

2015-11-30 21:43

administrator   ~0043465

Tested 1771. MMW no longer generates an AV, however, now, when the USB cable is removed, the sync process isn't terminated!

So for example, what can happen is:
1) Cable is unplugged while sync confirmation dialog appears
--> Sync confirmation dialog remains open asking the user to confirm the sync operation and allowing the sync to continue even though the device isn't connected!

Debug log of this attached.

OR

2) Cable is unplugged while MMW status is 'Removing content'
--> After cable is unplugged, sync status remains and the status bar continues to advance as if MMW is syncing!

rusty

2015-11-30 21:44

administrator  

bug_12981_LOG.zip (32,862 bytes)

Ludek

2015-11-30 22:07

developer   ~0043468

Last edited: 2015-11-30 23:31

View 6 revisions

re 1) Yes, I fixed the AV, but the dialog is still shown (waiting for user input)
=> Fixed in 1772 (auto-hide of the dialog)

re 2) Could you generate log of this ?

rusty

2015-12-01 07:29

administrator   ~0043472

2) I submitted a new log of this with the message
"bug 12981. AV when disconnecting cable during MTP sync freeze that occurs while 'removing content'"

Also, attached is a debug log that was generated while this occurred.

rusty

2015-12-01 07:30

administrator  

rusty

2015-12-01 08:04

administrator   ~0043474

3) I performed a USB sync with MMA dev settings for 'Allow deletion during USB sync' and 'Allow file notification during file sync' both disabled.

After the sync operation completed successfully, I disconnected the device
--> AV "bug 12981. Issue 3. AV when disconnecting cable after MTP sync.'

Logs attached.

rusty

2015-12-01 08:05

administrator  

bug_12981_issue-3_log.zip (250,896 bytes)

Ludek

2015-12-01 11:28

developer   ~0043478

Last edited: 2015-12-01 11:29

View 2 revisions

All fixed in 4.1.10.1772

peke

2015-12-08 01:48

developer   ~0043532

Verified 1774

peke

2015-12-08 03:28

developer   ~0043534

Reopen for analyze due the testing of 0012961 and noted in 0012961:0043533

Elf file is located inside "/MMW/bugs/bug12961/2015-12-08 01 Freeze.rar"

Ludek

2015-12-08 12:27

developer   ~0043541

Fixed in 1775

rusty

2015-12-11 04:03

administrator   ~0043598

I have not observed any crashes on disconnect with build 1775/1776. Leaving for Peke to close since he observed the last crash.

peke

2015-12-12 01:48

developer   ~0043623

Verified 1776

Crashes were not related to USB connection.