View Issue Details

IDProjectCategoryView StatusLast Update
0012948MediaMonkey (current)Synchronizationpublic2015-12-18 19:04
Reporterrusty Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1.9 
Target Version4.1.10Fixed in Version4.1.10 
Summary0012948: USB Sync: certain devices running MMA no longer recognized
DescriptionAs of the last 2 builds, USB synchronization seems to be broken--devices are no longer recognized in MMW.

Tested with Nexus 5 (marshmallow) and Tab 8 (kit kat)
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=21&t=82699&start=15#p416143

http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=82921

http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=82882

TagsNo tags attached.
Fixed in build1766

Relationships

related to 0012961 resolvedpeke MediaMonkey (current) USB Sync freezes when removing content 
related to 0012960 closedmarek MediaMonkey for Android USB Sync fails between MMW and MMA 4.1.3 

Activities

marek

2015-11-09 16:08

developer   ~0043267

It cannot be on MMA side: MMW recognizes the devices via MTP.

rusty

2015-11-09 16:55

administrator   ~0043268

This appears to be a case of MTP drivers that were 'frozen'. Rebooting solved the problem.

marek

2015-11-10 10:51

developer   ~0043275

It looks like more and more users observe this:

http://www.mediamonkey.com/support/staff/index.php?/Tickets/Ticket/View/29082/mytickets/-1/-1/-1/0

http://www.mediamonkey.com/support/staff/index.php?/Tickets/Ticket/View/29075/mytickets/-1/-1/-1/0

Maybe it should be checked on MMW side

Ludek

2015-11-10 12:55

developer  

SD card not show.png (23,467 bytes)   
SD card not show.png (23,467 bytes)   

Ludek

2015-11-10 12:56

developer   ~0043277

Last edited: 2015-11-10 12:59

View 3 revisions

Isn't it just that the SD card is disabled in options? See the attached screengrab.

I see the same, but it was designed this way that if '[ ] Sync to this location' is unchecked in MMA then the device also isn't shown in MMW interface. It is disabled in my case, I just don't remember whether I disabled it manually in MMA or MMA did it somehow automatically?

rusty

2015-11-13 06:37

administrator   ~0043300

Last edited: 2015-11-13 14:23

View 7 revisions

You can see at http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=82921 that users have confirmed that the profile is active (and some have confirmed that not only is it active, but it works for Wi-Fi sync but not for USB sync).

In addition, two users at http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=82882 indicated that even after deleting all sync profiles, that when the device is plugged in, MMW does _not_ create a profile for the SD card!!

Also, the eSupport ticket XKC-422-36414 shows that the user has enabled the SD card profile for an S5 (that makes 3 reports of this problem with an S5). Note that it also includes a dbgview log.

Another similar report for the S5 active: GGK-374-42905

Ticket SEW-232-84065 indicates the problem occurring with 4.1.9 and martin includes a forum link indicating that it doesn't occur with 4.1.6.

Ticket BGI-133-36226 seems to be another instance of this problem, but on an LG device.

New ticket 11/13: RRY-205-47901



One possible reason for the growing frequency and why it wasn't being reported as much upon the initial release of MMW 4.1.9 is that the problem may be related to Windows 10. Any other ideas?
Would it make sense for you to schedule a remote access session with the users?
btw, do you have an S5 to test this?

Ludek

2015-11-13 14:55

developer   ~0043304

Last edited: 2015-11-13 16:31

View 6 revisions

Based on the logs from RUB-786-43900 the SD card is now announced as CD drive that is ignored as ghost CD drive by MMW and removed from the tree.
Creating testing EXE for users to confirm...

BTW: I don't think it is Windows 10 related, because the user from RRY-205-47901 is on Windows 7, no idea what has changed the SD card storage presentation in Windows, probably an Android OS update?

Ludek

2015-11-14 00:40

developer   ~0043305

Last edited: 2015-11-14 00:49

View 5 revisions

This wasn't the root of the problem, but...

Two users confirmed (tickets XKC-422-36414 and RUB-786-43900) that the issue doesn't appear when MMA is uninstalled or MMA is lower or equals to build number 491. Whenever MMA 499 is installed, the issue appears even if MMA is closed.

So my guess is that it needs to be a change in the StorageInfo.xml file that MMW most probably fails to parse, asking the users for StorageInfo.xml file...

Ludek

2015-11-14 10:44

developer   ~0043306

Last edited: 2015-11-14 11:15

View 3 revisions

To clarify, the issue started when MMA added this:
<folder>/storage/ext_sd</folder>
for storages with
<type>read-write limited</type>

i.e. MMA added root folder as approwed by MMA user, i.e. whole SD card is approwed as read/write capable, but MMW crashes while parsing the value.

Fixed in MMW 4.1.10.1766


Note that to suppress the crash on MMW 4.1.9 and lower MMA should add the value like this:
<folder>/storage/ext_sd/</folder>
i.e. with the slash at the end

peke

2015-11-14 12:41

developer   ~0043307

Verified MMW part 1766

peke

2015-12-18 03:08

developer   ~0043722

Verified 525