View Issue Details

IDProjectCategoryView StatusLast Update
0001293MediaMonkey (current)Otherpublic2010-12-17 01:07
Reporterrusty 
PriorityimmediateSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version4.0Fixed in Version4.0 
Summary0001293: Download Manager
DescriptionIn order to better integrate with various online music stores, we'll need to implement some sort of basic download manager. The desired user experience is that the client and www service should almost apear to be on and the same.

At a high level, the desired functionality is to:
-Configure account information automatically
-Configure download location
-Automatically submit account information (e.g. username/password)
-Download multiple tracks in the background as efficiently as possible to the configured download location
-Provide feedback re. download status
-Automatically load the downloaded tracks into the library (note: the working assumption should be that the user does not have MM Gold)

I'll investigate some download managers to try and define this further.
Additional Information3 download managers to look at:
-Mozilla firebirds (minimalist but really nice)
-Emusic's
-Puretrack's
TagsNo tags attached.
Fixed in build1318

Relationships

related to 0003251 new Download Podcast episodes and other MP3s without subscribing 
related to 0000534 closedLudek Ability to share / stream library to other machines 
related to 0003360 closedLudek Use single internet access library instead of TIE + Indy 
related to 0005585 closedLudek Podcast episode downloads may be incomplete (due to network interruption) 

Activities

Ludek

2009-02-10 11:14

developer   ~0016604

Priority might be raised, because we are adding 0000534 where we might need a download manager to configure where to download UPNP content.

peke

2009-02-11 02:38

developer   ~0016615

Ludek,
From what I know it should be possible to use TIE as downloading engine for www/ftp and tie to very GUI of our choice?

Ludek

2009-04-16 13:48

developer   ~0017502

Last edited: 2009-08-06 14:37

Note that we should also handle interrupted downloads and allows their resume:
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=4455&highlight=--+Mixed+--&ticketsearchid=1589

In order to resume download we will need to add support for partial content by using range requests, more info here: http://benramsey.com/archives/206-partial-content-and-range-requests/


As discussed with Jiri we should add a download manager to MM 4.0 together with the UpNp functionality.

Edit (Rusty): Another example at:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=38691

Ludek

2009-08-28 19:22

developer   ~0018706

Last edited: 2010-05-28 14:00

The Download Manager functionality implemented in build 1300.

Web downloader functionality (based on the attached mockup) added in build 1307.

2010-05-28 13:59

 

Web_downloader_mockup4.0.png (262,418 bytes)

rusty

2010-10-15 21:18

administrator   ~0020785

Tested basic functionality in build 1316, and found:

1) On the eMusic site, all downloads fail

2) On the Amazon site, downloads aren't recognized

3) If the user goes to the Net Radio > Shoutcast node, MM opens up the download manager for the various Playlists that show up (which is fine).

The problem is that:
a) The playlists don't have any names (Titles). They should be named based on the Text that appears to the user.
b) The playlist is saved as unknown.pls (but all playlists have that name!). This would probably be fixed by a).
c) When the user downloads a playlist it doesn't remain in the Downloads list.

Ludek

2010-10-21 21:37

developer   ~0020898

Last edited: 2010-10-21 21:41

View 2 revisions

1) I tested this and MM really recognizes some downloads, but they are M3U playlists referencing just to MP3 samples. They were in relative form (/Samples/...m3u), I fixed them to be in the absolute (www.emusic.com/samples/...m3u).

Nevertheless I wouln't show them at all, I tested eMusic and they have their own Download Manager application that needs to be installed on the user machine and all the downloading goes via the app (eMusic Download Manager).
I haven't tested the Amazon, but I guess they use a similar strategy.

Therefore I think we shouldn't show our Download View for these default sites (Amazon, eMusic), because our download view is useful just for free music servers like http://freealbums.blogsome.com/ where we can get the direct link to the audio/video file to download.

3a) Fixed.
3b) Fixed.
3c) If you think under Downloads node, it is there, but just for a while until the small PLS file is being downloaded, keep it mind it is very small (<5KB).

Beside these issues I fixed several others that I have found during testing in build 1317:

4) Context menu (Resume, Pause, Cancel) commands were sometimes enabled although they shouldn't be.
-> Fixed

5) Failed downloads sometimes remained under the Downloads node.
-> Fixed

6) It could happen that download item could look like being in progress although it actually wasn't.
-> Fixed

peke

2010-12-17 01:07

developer   ~0021877

Verified 1335