View Issue Details

IDProjectCategoryView StatusLast Update
0012926MediaMonkey for AndroidGeneralpublic2015-11-03 22:34
Reporterrusty Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.1.3 
Target Version1.2.0Fixed in Version1.1.3 
Summary0012926: Clean install: library folder settings are blank (regression - release build)
DescriptionWhen doing a clean install and running the _Release_ build for the first time, permission settings are incorrect and library folder settings are blank (this issue does not occur with Beta builds--see related bug 0012924 ).

For devices with external storage, it prompts only for permissions for SD Card /Playlists/ (and doesn't include /Music/ and /Videos/ as the beta build does). Moreover, upon visiting Options > Choose Library folders, no folders (internal or external) are enabled by default (despite having given permissions for the entire SD card)! The net result is that no content is in the library despite content existing in both internal memory and SD card.

Logs generated with Idol 5/Android 5.0.2
Logs after granting permissions to SD card on startup (when only prompted to grant access to playlists): 1CSZR848S1
Log after visiting the Choose library folders dialog (in which nothing is selected): V8JTTJ0NGA

Note: the problem occurs similarly on a clean install of build 493 (release) to a Nexus 5 running Marshmallow (which has no external storage). Media content on the device doesn't appear at all because the default Library Folder settings are blank!
TagsNo tags attached.
Fixed in build496

Relationships

related to 0012924 closedmarek On initial run, device content doesn't scan (regression in beta builds) 

Activities

marek

2015-10-28 07:36

developer   ~0043196

Please resend new logs from build 493. I have enabled logs that are disabled by default in release builds.

rusty

2015-10-28 11:34

administrator   ~0043198

Logs generated with Nexus 5/Android 6
Log after visiting Tracks view (empty): 6HXA2VGO1V
Logs after granting permissions to SD card on startup (when only prompted to grant access to playlists): Not Relevant (No SD card)
Log after visiting the Choose library folders dialog (in which nothing is selected): R1Y1C6W8WN

--

Logs generated with Idol 5/Android 5.0.2
Logs after granting permissions to SD card on startup (when only prompted to grant access to /playlists): YYOSN0G6AJ
Logs after visiting tracks view (empty): 57261OY4V0
Log after visiting the Choose library folders dialog (in which nothing is selected): VP8VMWQOQ8

marek

2015-10-31 15:41

developer   ~0043210

I can't reproduce and logs does not contain the moment when it disappears but I have fixed many related issues. So it is probably fixed.

Fixed in build 494

rusty

2015-11-01 00:52

administrator   ~0043213

Last edited: 2015-11-01 01:54

View 4 revisions

Tested 494 and the bug still exists:
a) on Nexus 5/Marshmallow, running a clean install of MMA on a device that has plenty of content shows nothing, because the default Android library folders aren't preselected by default. Once they're selected by the user, the content appears.
- Log after visiting Tracks view (empty): TYFUEI0AKE
-Upon visiting the Choose library folders dialog, nothing is selected (i.e. the library folders that should be enabled by default (/Music, /Movies, /Playlists) aren't! Log after selecting these folders (which causes the tracks to appear):
OZNRGV53S0

b) On the Alcatel Idol 3 running Android 5.0.2, user is only prompted to grant access to SD Card /Playlists (not /Music or /Movies or /Videos) and even after granting access to the entire SD Card, no content displays (despite the fact that content exists in /SD Card/Music. As in case a), the reason that no content displays is that upon subsequently visiting 'Choose library folders', no folders are enabled (on either the internal memory nor on the SD card).

Debug log after granting access to SD Card and tracks are empty: W2CUE39ZB2
Log after visiting the 'Choose library folders' dialog in which nothing is selected: XEC5VAM7CJ
Debug log after visiting the 'Choose library folders' dialog and selecting relevant media folders on the SD card and on the internal memory, causing all content to appear in the library: L2BKJ7YRSB

So to summarize: on clean installs for both devices, any existing media aren't detected because the default 'Choose library folder' settings are that no folders are selected. Strangely, as documented at 0012924, this problem with the default settings isn't nearly as bad in the beta builds.

marek

2015-11-02 21:08

developer   ~0043229

Stable build skipped folder initialization. Added workaround and fix. Need to be verified by Martin.

Fixed in build 495

rusty

2015-11-03 03:42

administrator   ~0043233

Last edited: 2015-11-03 03:59

View 2 revisions

Verified 495:

a) on Nexus 5/Marshmallow, first run on clean install content appears as expected, and 'Choose library folders' shows that /Music, /Movies are correctly preselected by default.

b) on Idol 3/Lollipop, first run on clean install, after granting access to /Music, Videos, Playlists
--> Content appears immediately for both internal and external content.
--> Choose library folders shows that the following are enabled: Internal:Movies,Music; External:Music,Videos.

Note: I also tested on Tab 8 / Kitkat for regressions; it preselects the following folders:
Internal: /Movies/, /Music,
SD Card: /Movies (/Music isn't selected by default because it doesn't exist on the device)
Synchronization works correctly, all views display as expected.

Setting to 'Feedback required' for Martin to verify the fix.

martin

2015-11-03 17:29

developer   ~0043239

Fixed in build 1.1.4.496

rusty

2015-11-03 22:34

administrator   ~0043249

Verified 496.