View Issue Details

IDProjectCategoryView StatusLast Update
0012860MediaMonkey 4Playerpublic2018-07-06 06:45
Reporterpeke Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1.9 
Target Version4.1.10Fixed in Version4.1.10 
Summary0012860: Some tracks do not show correct playing time
DescriptionSome tracks do not show correct playing time especially if user seeks within that track.

Sample track from Ticket clearly show that behavior when you seek to middle of track and than leave it to play till the end.
Additional InformationKCS-500-88371
TagsNo tags attached.
Fixed in build1765

Relationships

related to 0011900 resolvedLudek MediaMonkey 4 Format: Better handling of Corrupted and Incorrect files 
related to 0014948 closedmichal MediaMonkey 5 Crash after playing some MP3 files. 

Activities

michal

2015-09-24 10:03

developer   ~0042975

Last edited: 2015-09-24 10:06

View 3 revisions

The problem seems to be in WM layer. During seek we only call methods of Microsoft's IWMReader interface. I do not see any solution in this plugin, because we cannot affect, how WM layer handles seek and current playback time.
But, for Windows 7 and later, we could use Media Foundation for MP3 decoding (in_mfaudio plugin), it seems to handle this file right. Currently we use it for M4A/M4B/ADTS/AAC. We could simply add MP3 to be handled by this plugin by default.

Assigning to Jiri for decision. It could be quite risky, there could be some hardly predictable bugs in MF decoding of MP3. Anyway, it seems to decode M4A quite well, so maybe we could try it for MP3 too.

rusty

2015-09-24 22:12

administrator   ~0042980

It could be risky to change the default behavior this late in the beta cycle, though we could make it a config option (or just defer until the next release).

Ludek

2015-09-25 15:06

developer   ~0042990

Last edited: 2015-09-25 15:09

View 3 revisions

I don't believe that the INI switch solves something, 99% of users won't realize that such a switch exists, IMHO we could try to change the default to MF in the next beta cycle and see what happens

jiri

2015-09-29 07:48

administrator   ~0043004

Testing this approach in the next beta cycle seems to make most sense.

peke

2015-10-11 00:16

developer   ~0043088

Some files show incorrect Time/length but actually they are in completely different format. See 0011900:0043087 for more details

michal

2015-10-16 10:47

developer   ~0043139

Fixed in build 1765. MP3 files will be played by Media Foundation (in_mfaudio plugin) where possible, from now on.

peke

2015-11-12 13:07

developer   ~0043289

Verified 1765