View Issue Details

IDProjectCategoryView StatusLast Update
0012846MediaMonkey for Android[All Projects] Generalpublic2015-09-11 12:05
Reporterrusty 
PriorityimmediateSeverityblockReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.1.3 
Target Version1.1.3Fixed in Version1.1.3 
Summary0012846: Failed synchronization / data loss MMA 468 / MMW 1756 (regression)
DescriptionMMA Build 468 cannot sync to SD card. All tracks fail to sync even after I've deleted the profile and recreated a new one. Tested on Samsung Tab Pro 8.4 running kitkat.
Log: A77AHO7KFD

Synchronization worked correctly for _internal_ storage, but when MM crashes (crash occurred in relation to an hdmi cable being plugged in) all data was lost (the db appeared empty after the crash)!

 
Steps To Reproduce1 I tried to WiFi sync content to the SD card, but that failed. The content just wouldn't sync--there was an error that xx tracks failed to sync (where xx was all of the new tracks). This occurs even after deleting the profile and attempting to sync again.

2 Then I deleted the profiles in MMA and MMW, and resynced, but this time to internal memory. That was successful, and everything seemed to be working correctly. UNTIL, I plugged in an hdmi cable and attempted to play a video via MMA. That resulted in a crash, and when MMA restarted, all of the content in MMA was lost.

Note: The 'Choose library folders' dialog in MMA shows all of the paths containing MMA data. i.e.:
/Android/data/com.ventismedia.android.mediamonkeybeta/files
/Download/
/Movies/
SD Card
/Android/data/com.ventismedia.android.mediamonkeybdeta/files/

BUT, I see that the content isn't stored to /Android/data.ventismedia.android.mediamonkeybeta/files, but rather it was synced to /Music

And when I look at MMW, Locations for Music is configured to:
\Music\<Album Artist>\<Album>\<Track#:2> $Left(<Artist>,20) - <Title>

I guess then the question is:
1) Why did the db get deleted on crash? (note that Google Music app continued to show the tracks and the playlists)
2) Why isn't MMA configured to scan the /Music directory?
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=82123
TagsNo tags attached.
Fixed in build476

Activities

rusty

2015-09-08 18:12

administrator   ~0042925

Note: I tested MMA 466 to see when the problem was introduced, and it seems that even in build 466 there are problems re. MMA being confused between internal and external memory. I configured MMA to sync a playlist to external storage, and MMA:
1) Matched the device contents on internal storage and then synced the content to internal storage instead of external storage (even though that the internal storage profile is disabled in MMA)
2) generated an error that none of the contents were synced to external storage

Note that this previously worked flawlessly.

rusty

2015-09-09 03:56

administrator   ~0042926

Tested build 471 and the problems persist.

Initial library folder settings:
Internal storage:
/Movies/
/Music/
SD card
/Movies

1 initial sync of 'Bronski beat' playlist to internal storage:
--> sync screen briefly flashes 'Synchronization initializing', and no tracks sync
--> Debug log: 01XPQF8VGK
--> Library folders settings are changed to:
Internal storage:
/Movies/
/Music/
/Playlists/
SD card
/Android/data/com.ventismedia.android.mediamonkybeta/files/Playlists/
/Movies
/Playlists
Note: it's kind of strange that the SD card settings were changed considering that the SD Card sync profile is disabled.
 
2 sync of 1-Bar Mitzvah playlist to SD card
--> Sync appears to succeed, but after it has completed, an examination of the library shows that neither the tracks nor the playlists appear!!
--> Debug log: A83JABWVJE
--> An examination of the library folders at this stage shows that they remain as:
Internal storage:
/Movies/
/Music/
/Playlists/
SD card
/Android/data/com.ventismedia.android.mediamonkybeta/files/Playlists/
/Movies
/Playlists

And the reason that the tracks don't appear is that they've been synced to /Android/data/com.ventismedia.android.mediamonkeybeta/files/Music/
(verified in ES Explorer, but surprisingly, the tracks don't appear in Google Play Music either i.e. the mediastore hasn't been updated)

Playlist .m3u files don't appear in either of the expected SD card locations

3 Enable 'Delete unselected content copies' for the SD Card profile
--> the synced files aren't deleted from the device!!

Ludek

2015-09-09 11:57

developer   ~0042927

Last edited: 2015-09-09 12:29

View 4 revisions

Investigated further with Marek and the user and results are:

1) The profile names get swapped somehow, we found that if you change the profile settings in MMA, then MMA sends also the device profile (storage) name and in one point it most probably sent the swapped names. Now, it seems to be ok, also based on the user's log files the names are no longer swapped. Workaround is to change the profile settings in MMA (e.g. uncheck and check again the [x] Sync to this location checkbox) to force MMA to send the new (and correct) storage name to MMW. Marek will tweak it in next MMA version.

2) MMA somehow auto-unchecked the library folders to which the content from MMW was synced, thus content from MMW was synced, just was not visible in MMA. The workaround is to enable this library folders in MMA again. This is investigated by Marek and tweaked in next MMW build (1758) to ensure that the folders in the sync masks (MMW -> Device -> Options -> File Locations) are always added.

rusty

2015-09-09 14:53

administrator   ~0042928

Re. item 1) (swapped profile names), in my tests described at 0012846:0042925, I had done a clean install of MMA and deleted the sync profiles in MMW, before initiating a wi-fi sync. So when you write that 'now it seems to be ok', I'm not sure that it is ok--my tests were with MMA 471/MMW 1757.

marek

2015-09-09 15:13

developer   ~0042929

To summarize:

In build 471, I have fixed issue 1) from issue details. I.e.:

"I tried to WiFi sync content to the SD card, but that failed. The content just wouldn't sync--there was an error that xx tracks failed to sync (where xx was all of the new tracks). This occurs even after deleting the profile and attempting to sync again."

The bug was in generation of path for external storages only on Kitkat devices. All tracks failed to download.

In build 472, I have fixed a different issue 1) from http://www.ventismedia.com/mantis/view.php?id=12846#c42926:

It was caused by something else. I have found a regression that caused that first storage was processed with settings from second storage.

Now we will see whether the issues with disappearing of scanned folders will persist. I will probably need a log right after it disappears. It is quite random.

rusty

2015-09-09 19:07

administrator   ~0042931

Last edited: 2015-09-09 19:08

View 2 revisions

Tested build MMA 172 vs MMW 1757:
1 Sync to internal storage works as expected

2 Sync to external storage fails as described in 0012846:0042926 item 2 (the tracks appear to sync, but the tracks and the playlist don't appear in MMA)
Debug log DVNZQAABXE

The reason for the failure seems to be as described above: The library folders --> SD Card settings only include the following paths:
/Android/data/com.ventismedia.android.mediamonkybeta/files/Playlists/
/Movies
/Playlists

Strangely, if I do the workaround of enabling the Library folder '/Android/data/com.ventismedia.android.mediamonkybeta/files/' the tracks still fail to appear even though the files _are_ visible in /Android/data/com.ventismedia.android.mediamonkybeta/files/music/<artistname> (checked using a file browser)!!

rusty

2015-09-09 21:15

administrator   ~0042932

Tested MMA 172 vs MMW 1758:

Test results are exactly as above.

Note also, even if I do the workaround of enabling the Library folder '/Android/data/com.ventismedia.android.mediamonkybeta/files/' and then sync, the synced files do _not_ appear in MMA even though they _are_ on the device.

Also, note that in MMW, the SD Card device profile shows a path of /Music/... (and not /Android/data/....).

rusty

2015-09-10 22:15

administrator   ~0042933

All of these issues seem to be resolved in MMA 475 vs MMW 1758.

Waiting for a new MMA build in which the extra logging is removed.

marek

2015-09-11 12:05

developer   ~0042935

Fixed in build 476