View Issue Details

IDProjectCategoryView StatusLast Update
0012838MediaMonkey (current)Playerpublic2017-10-22 00:19
Reporterlowlander 
PriorityimmediateSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version4.1.8 
Target Version4.1.19Fixed in Version4.1.19 
Summary0012838: Play from Windows Explorer takes long time
DescriptionUsers are reporting that it takes long for MediaMonkey to start playing when a file is opened from Windows Explorer.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=7&t=68586
TagsNo tags attached.
Fixed in build1856

Activities

Ludek

2017-02-23 16:19

developer   ~0047334

Last edited: 2017-02-23 16:21

View 2 revisions

Some additional info: http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=68586&start=15#p426910

Users are saying that it happens only when:
- the double-clicked track isn't in library
- when in Options > OS Integration
The "Show context-menu actions for:
is enabled.

Disabling the context actions is a workaround according to the users.

rusty

2017-02-23 16:56

administrator   ~0047335

I can confirm this in 4.1.15.1828.

Abba - Double click when MM isn't running
--> playback starts in 8 seconds

Abba Waterloo - Double click when MM is already running
--> playback starts in 20 seconds, but may be due to podcasts downloading

ABC - The Look of Love - Double-click when MM is already running after podcast dl completes
--> playback starts in ~10 seconds

Debug log for the above posted to ftp.

In contrast: Starting playback in Clementine
--> playback starts in 3s

petr

2017-02-24 12:24

developer   ~0047347

Fixed

rusty

2017-02-24 19:00

administrator   ~0047356

With build 1830 it takes about 25s to play a local track from Explorer in MMW. Same track takes 2-3s in Clementine.

rusty

2017-02-24 19:16

administrator   ~0047357

Re-resolving. The problem went away once I restarted MM.

peke

2017-02-24 21:54

developer   ~0047362

Verified 1830

Ludek

2017-10-16 17:42

developer   ~0048973

Users are reporting that this is still an issue:
http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=68586&p=440104#p436572

rusty

2017-10-16 17:53

administrator   ~0048974

Last edited: 2017-10-16 18:09

View 6 revisions

I was able to replicate:
1 Right click 'Perfect-Alanis Morissette'
--> Error Log "Error loading type library/DLL." submitted. Description: "Attempt to 'Play in MediaMonkey' from Explorer --> Error " (around 1:44pm)
--> About 45s after the error log was sent, MMW ran and played the track

Note:
- the bug occurs when right-clicking in Explorer and MMW isn't running. If MMW is already running, then playback works correctly.
- the bug occurs consistently (i.e. restarting MMW doesn't resolve the problem).

EDIT: I replicated the bug again, this time with dbgview running.
1 Right click 'Ironic-Alanis Morissette'
--> Error Log "Error loading type library/DLL." submitted. Description: "bug 0012838" (around 2:04pm - line 45 in the log)
--> About 1:30s after the error log was sent, MMW ran and played the track
Debug log attached.

rusty

2017-10-16 18:10

administrator  

bug_12838.7z (21,675 bytes)

rusty

2017-10-17 14:22

administrator   ~0048977

A couple of additional points:
- 'Open with'>'MediaMonkey' results in the exact same buggy behavior (again, provided that MediaMonkey isn't already running).
- 'Open with'>WMP, iTunes, Clementine all work correctly.

petr

2017-10-17 18:08

developer   ~0048978

Fixed

rusty

2017-10-17 20:22

administrator   ~0048980

Last edited: 2017-10-17 20:30

View 4 revisions

The bug still occurs with 1855:
I sent an elog entitled "bug 0012838 with build 1855"
Debugview log attached.

fyi, I just noticed something else: After right-clicking 'Play Now in MediaMonkey' then the ELog is sent and Process Explorer shows "MEDIAM~2.EXE" running at 45% CPU utilization for 90s at which point it changes to "MediaMonkey.exe" and MediaMonkey launches/plays.

rusty

2017-10-17 20:22

administrator  

bug_12838_build_1855.7z (25,339 bytes)

rusty

2017-10-18 05:08

administrator   ~0048986

Last edited: 2017-10-18 05:32

View 2 revisions

Tested all the way back to MMW 4.1.7.1741 and the eLog error "Error loading type library/DLL" and delay in launching still occurs on this machine. My guess is that the problem occurs on such old builds because installing an old build on top of a newer one doesn't undo whatever config issue is causing this problem.

As far as possible underlying causes I wonder whether it could be related to registry changes in 4.1.18 vis a vis firewall config OR perhaps related to Portable installs on the machine of MM4 or MM5.

Note also:
-the bug occurs with both regular and debug builds
-disabling skinning doesn't solve the problem
-terminating most other apps doesn't solve the problem
-I've attached screen captures illustrating properties of the file from Process Explorer
-I was unable to replicate the problem on a Windows 7 machine

rusty

2017-10-18 05:09

administrator  

12838_fail1.jpg (52,531 bytes)
12838_fail1.jpg (52,531 bytes)

rusty

2017-10-18 05:09

administrator  

12838_fail2.jpg (53,740 bytes)
12838_fail2.jpg (53,740 bytes)

rusty

2017-10-18 05:09

administrator  

12838fail3.jpg (47,460 bytes)
12838fail3.jpg (47,460 bytes)

rusty

2017-10-18 05:09

administrator  

rusty

2017-10-18 17:38

administrator   ~0048991

Upon further testing, I've noticed some very strange behavior:
- copy MediaMonkey.test.exe to the /MediaMonkey library, renaming mmtest.exe to MediaMonkey.exe (and MediaMonkey.exe to MediaMonkey.orig.exe), right-click play --> delay
- close MM, rename mm.orig.exe to MediaMonkey.exe (after renaming MediaMonkey.exe to MediaMonkey.test.exe), right-click play --> success!!

Once success occurs, it _always_ works until the user runs the installer to re-install MM, and then the bug starts occurring again.

Note: the process to get rid of the delay does not work consistently, however, I've been able to follow the process 3 times in order to 'solve' the bug.

petr

2017-10-20 21:13

developer   ~0049017

Fixed. Actually there were 2 issues.
1. long delay before playback starts - long standing issue where first double-click on track in explorer run MM with -Embedding parameter (which runs MM DCOM server in automation mode) and for any reason, subsequent run of the same DCOM server in automation mode cause delays ... so first open is fast, but when attempting to open a new song (with MediaMonkey already running) it takes more than 30 seconds.

2. crash with "Error loading type library/DLL" - for some unknown reason GetLongFileName sometimes return incorrect (non existing, probably historical) path ... this cause crash because system cannot create DCOM server from non existing exe.

peke

2017-10-22 00:19

developer   ~0049022

Verified 1856

Startup times are 3-5 Sec and subsequent starts are almost instantaneous.