View Issue Details

IDProjectCategoryView StatusLast Update
0012806MediaMonkey (current)Synchronizationpublic2015-07-24 11:29
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionfixed 
Product Version4.1 
Target Version4.1.9Fixed in Version4.1.9 
Summary0012806: iOS8: In some cases audio doesn't match title on iPhone
DescriptionThere were several reports that iPhone can get to state when titles on the device doesn't match the actual audio content.

I haven't been able to replicate, but found that it can happen in case of an unexpected iPhone reboot ( 0012774 ), the reason is explained in 0012750 , the iTunesCDB cannot be uploaded because of the reboot and after the device/MM restart MM thinks that the already synced files doesn't exist on device. Thus it generates filenames like /iTunes_Control/Music/F01/_Mas.mp3 that might been already used for another file in the previous sync (that exists on the device, but MM thinks it does not).

To simulate the issue:
1) Sync one Album1 from Artist1
2) Run iFunBox and manually delete the /iTunes_Control/iTunes/iTunesCDB file
3) Sync Album2 from Artist1
=> the content is mixed

The solution should be 0012750 that was finally reverted, another solution is 0012266 that has also some cons as described here 0012266:0041251
TagsNo tags attached.
Fixed in build1752

Relationships

related to 0012774 closedLudek iOS 8.3+ device reboots unexpectedly during long sync tasks (more than 5000 songs) 
related to 0012750 closedLudek iOS sync: Upload iTunesCDB more often (not only on the sync end) 
related to 0012266 closedLudek iOS5+ sync: Read device content rather from MediaLibrary.sqlitedb 

Activities

Ludek

2015-07-24 11:29

developer   ~0042753

Last edited: 2015-07-24 11:30

View 2 revisions

I used solution similar to 0012750, now the content should be always in sync, because iTunesCDB is uploaded after each successful "Air Sync" commit batch.

Fixed in 4.1.9.1752