View Issue Details

IDProjectCategoryView StatusLast Update
0012769MediaMonkey 5[All Projects] Generalpublic2017-11-23 01:00
Reporterpeke 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version5.0Fixed in Version5.0 
Summary0012769: OGG: Some OGG files are not supported
DescriptionSome ogg files are not read by MMW

Sample uploaded to FTP
TagsNo tags attached.
Fixed in build2073

Relationships

has duplicate 0009896 closedjiri MediaMonkey Wishlist Add support for OPUS codec 
has duplicate 0013194 closedmichal MediaMonkey (current) OGG: do not play in MMW and nor read correctly 
has duplicate 0014533 closedjiri MediaMonkey 5 OPUS codec 

Activities

michal

2015-06-23 06:13

developer   ~0042660

The file is in OGG Opus format, currently we support only OGG Vorbis. Opus is relatively new audio format, we should consider making support for it at least in MM5.
Opus doc: http://opus-codec.org/

jiri

2015-06-23 07:43

administrator   ~0042661

Last edited: 2015-06-24 12:15

View 2 revisions

Per IM discussion, we should try to add support asap, particularly for the decoder, but preferably also for the encoder. Backporting to MM4 also seems to make sense.

michal

2015-07-09 11:29

developer   ~0042697

Opus decoder implemented and merged to F_OGG plugin. Vorbis decoder moved from in_vorbis to F_OGG too. Tagging of Opus supported (same tags as OGG Vorbis, replay gain not supported correctly yet, see point 2 below)
Currently only MM5 affected (will marge to MM4 later, after solving issues).
Issues remaining:
1) radio streams are not working with f_ogg plugin, to be discussed
2) replay gain is handled differently in Opus format, not implemented yet, to be discussed (description: https://wiki.xiph.org/OggOpus)

jiri

2015-08-21 12:31

administrator   ~0042840

Per IM discussion, we probably won't merge this to MM4 branch, since it isn't trivial.

Other sub-issues will be moved to separate Mantis issues.

peke

2017-07-18 00:57

developer   ~0048384

Moved to MM5 where main tests will be done.

michal

2017-07-18 11:52

developer   ~0048385

Last edited: 2017-07-18 11:53

View 2 revisions

Fixed in build 2073. Should work for local files and live streaming too. Replay gain not implemented, create issue, if needed.

peke

2017-11-23 01:00

developer   ~0049239

Verified 2083 Left resolved till Gain Implementation is discussed.