View Issue Details

IDProjectCategoryView StatusLast Update
0012672MediaMonkey (current)Playlist / Searchpublic2016-01-29 14:10
Reporterlowlander 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionopen 
Product Version4.1.6 
Target Version5.0.0Fixed in Version 
Summary0012672: Type to fails to jump in Artist field in AutoPlaylist sorted with Artist & Title
DescriptionCreate an AutoPlaylist sorted on Artist > Title. Then use type to jump to a track and this is done on Title. Manual sorting Artist > Title in the AutoPlaylist fixes this.

Note that Title > Artist sort in AutoPlaylist doesn't change the behavior.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=1&t=80357
TagsNo tags attached.
Fixed in build

Activities

peke

2016-01-28 17:01

developer   ~0044014

Is it possible to do type search based on Column Selected eg. One click on track in Artist column and than type to navigate?

Ludek

2016-01-29 10:36

developer   ~0044017

Last edited: 2016-01-29 10:39

View 3 revisions

I think it always worked like this and like designed.

i.e. the default incremental searching is performed on Title column (until user click another column headings to change this). It doesn't make much sense to make this somehow depended on the auto-playlist's sort order, because for most of the sort fields the incremental search would be useless (e.g. those sorted by 'Added' or 'Random').

What do you think Rusty?

Note that in MM5 it currently works a little bit better -- instead of incremental search the tracklist is "filtered" so only tracks with the given prefix in any field are shown. So from my perspective this issue is already fixed in MM5 ?

rusty

2016-01-29 14:10

administrator   ~0044023

Setting target to MM5 and tagging as resolved since it's been fixed.