View Issue Details

IDProjectCategoryView StatusLast Update
0012609MediaMonkey (current)Synchronizationpublic2015-03-10 22:22
Reporterrusty Assigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1.6 
Target Version4.1.6Fixed in Version4.1.6 
Summary0012609: Wi-Fi sync: terminates prior to completion
DescriptionWhen syncing MMA 398 vs MMW 1733, Wi-Fi sync operations on large playlists (e.g. 2500+ tracks) terminate before the sync has completed, and the user must sync again to get it to complete.

MMA debug log: BS81P5K0YF

A user at http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=79200#p402578 is also complaining of this and has submitted logs.
TagsNo tags attached.
Fixed in build1736

Relationships

related to 0012591 resolvedmarek MediaMonkey for Android Wi-Fi Sync completes after partial sync (regression) 
related to 0012138 closedLudek MediaMonkey for Android Wifi sync doesn't respect reserve space setting 

Activities

rusty

2015-02-20 16:41

administrator   ~0042145

Note: in my case, the problem was that the Wi-Fi connection was somehow compromised by doing a wi-fi sync (disabling and re-enabling wi-fi sync solved the problem). My guess is that it's a problem with the wi-fi drivers rather than with MMA.

So just have a look at the user's logs.

marek

2015-02-23 13:25

developer   ~0042157

Last edited: 2015-02-23 13:35

View 3 revisions

Yes it is probably connection failure. I am not able to see it because he made two other syncs that were successful and I do not see the failure.

We should probably improve the way how to handle it.

Now we try to reconnect twice on lowest level and then we terminate. We also check the wifi but it will always interrupt whole sync.

Better solution will be to pause the sync when connection fails and try to get more info about what happened.

1. Wifi was disabled (but was enabled at the beginning of sync)
    - ask user to re-enable it.
    - interrupt on decline
2. IP is not reachable
    - show some dialog about waiting for server (similarly to e.g.Skype - TRYING TO RECONNECT)
    - try repeatedly (each 5 seconds) to ping the IP
    - interrupt whole sync after e.g. 2 minutes
3. File is not reachable, IP is reachable
    - file doesn't exist but server is ok
    - skip and continue

This can be implemented to 1.1.1

marek

2015-02-23 13:33

developer   ~0042158

I asked user for another log to be sure about it...

rusty

2015-02-24 20:11

administrator   ~0042175

Last edited: 2015-03-02 17:14

View 2 revisions

Logs submitted at: http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=79200#p402578

Note, according Marek, this is most likely an MMW issue: "MMW builds a sync list according free space on device. So this synclist is too short. I am not sure where the problem is but most probably it is caused by autoconverted tracks where MMW has to guess final track size..." possibly specific to WMA (I've never observed this problem with auto-conversion to MP3).

Ludek

2015-03-02 19:17

developer   ~0042234

Last edited: 2015-03-02 19:26

View 3 revisions

By a quick look at the debug log it really seems related to optimization re 0012138

The user have all songs in WAV format and converts to WMA (VBR) files, there is most probably inaccurate estimation for WMA Pro, VBR (Quality 60%), Sample rate 44100Hz, Channels - Stereo.

The workaround is to perform another sync.

Ludek

2015-03-02 19:29

developer   ~0042235

Last edited: 2015-03-02 19:31

View 2 revisions

yes, it is definetly bad estimation for "WMA Pro", VBR (Quality 60%), it shows only 4KB as resulted size for 5MB source WAV file.

This is not the case for standard WMA

Ludek

2015-03-02 21:03

developer   ~0042236

Fixed in 4.1.6.1736

peke

2015-03-02 23:43

developer   ~0042237

Veified 1736

1.7 GB calculated size of 972 WMA files from FLAC and WAV previously in 1735 size was 12MB :) (Range from 4-12KB) Space on my Moto G was 2.1GB so it finshed without problems FLAC/WAV Total Size 23.9GB prior to Sync space calculations.