View Issue Details

IDProjectCategoryView StatusLast Update
0012545MediaMonkey (current)Synchronizationpublic2020-09-21 17:36
Reporterlowlander Assigned To 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version4.1.6 
Target Version4.1.6Fixed in Version4.1.6 
Summary0012545: iTunes 12.1 update on 64-bit OS results in Apple device no longer being recognized
DescriptioniTunes and/or iOS update results in Apple device no longer being recognized
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=12&t=79043
http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=79038
BZX-209-48588, ZBO-903-59727, HVO-290-91044, SNT-169-39403, AGR-872-33482, KPS-807-93322, GOA-649-98903, DHY-888-18076
TagsNo tags attached.
Fixed in build1731

Relationships

parent of 0012590 new MediaMonkey (current) Rename helper/additional processes? 
parent of 0012684 closedLudek MediaMonkey (current) iPod Touch 1G or iPhone the first generation fail to auto-sync (regression in 4.1.6) 
has duplicate 0012547 closedpeke MediaMonkey (current) Apple Device sync: Synchronization issues after upgrade to iOS 8.1.3 
related to 0016934 assignedLudek MediaMonkey 5 iOS devices not syncable after update to iTunes 12.10.9 
Not all the children of this issue are yet resolved or closed.

Activities

peke

2015-02-03 03:21

developer   ~0041935

I've tested with iPhone 4s with both 8.1.2 (No issues at all) and immediately after update (OTA) with 8.1.3 same MMW (1728) and iTunes version (11.4.0.18) LOG Supplied on FTP where sync took abnormally long for 82 tracks and most of time iPhone didn't show sync icon in notification.

peke

2015-02-03 03:49

developer   ~0041937

I installed 12.1.0.71 update over the top of 11.4.0.18 (it failed first time and I needed to rerun update) neither MMW nor iTunes recognized the phone (LOG Fetched from MMW). Strangely driver seams to be correctly installed and Zentimo (an USB/Removable Devices manager) correctly recognizes that device is inserted (Device info fetched)

After bit struggle I reverted back to iTunes 11.4.0.18 and device started to be recognized again without any isues.

1. Next I've done full uninstall http://support.apple.com/en-us/HT1923 and run deep registry cleanup.

2. After installing iTunes 12.1.0.71 x64 (x86 refused to install) again even itunes didn't recognized iPhone and each time I plugged iPhone UAC prompt showed that Apple mobile service wants to start/stop

3. done restart of PC with iPhone plugged in

4. Now service looks like correctly started

5. MMW still do not recognize the iPhone

6. Starting iTunes and after UAC prompt and allowing iTunes to access internet it recognized teh phone and I set it as new device

7. After itunes activated device notification MMW also recognized iPhone like nothing happened (New Log fatched)

I uploaded also Apple log files to trace internal import/export functions

Ludek

2015-02-03 18:40

developer   ~0041943

Last edited: 2015-02-03 20:39

View 16 revisions

I have just tried with my iTouch5 and I can confirm that it is iTunes 12.1 cuases the issue. After upgrade to iOS 8.1.3 the device was still recognized by MM, but after iTunes upgrade MM does not show the device at all (unlike iTunes)

The reason is that iTunes is now a full 64-bit application (http://support.apple.com/kb/DL1614) and MM accesses only 32-bit registry / DLLs (while it needs to access 64-bit registry view in order to find right path to the iTunesMobileDevice.dll that is now 64-bit DLL though)

Working on a solution...

Some useful links:
http://stackoverflow.com/questions/339848/is-it-possible-to-access-a-64-bit-dll-from-a-32-bit-application
http://codeverge.com/embarcadero.delphi.non-tech/call-64bit-dll-s-function-from-32/1070273
http://docwiki.embarcadero.com/RADStudio/XE6/en/64-bit_Windows_Application_Development
http://cc.embarcadero.com/Item/27667

Basically we need to create another intermediate process (64-bit) that will communicate with the DLL.

Ludek

2015-02-06 00:42

developer   ~0041978

iMazing "solves" this just by adding KB article about iTunes reinstall: http://support.digidna.net/hc/en-us/articles/204558067-iTunes-12-1-Update-on-Windows-Prevents-Device-Connection

peke

2015-02-06 02:28

developer   ~0041980

Last edited: 2015-02-06 02:29

View 2 revisions

I can confirm iMazing solution and I created KB article to address this in MMW

http://www.mediamonkey.com/support/index.php?/Knowledgebase/Article/View/227/0/itunes-update-121071-of-windows-x64-breaks-synchronization

Ludek

2015-02-13 19:00

developer   ~0042046

Last edited: 2015-02-13 19:04

View 2 revisions

Fixed in build 1730.

If the 32-bit version of iTunesMobileDevice.dll does not exists then MM launches a new 64-bit process called "x64MMHelper.exe" that communicates with the 64-bit version of the DLL.

peke

2015-02-14 00:02

developer   ~0042050

Last edited: 2015-02-14 00:12

View 2 revisions

Not fixed. MMW do not detect Touch 4G nor iPhone 4S

New logs on FTP

Ludek

2015-02-14 00:46

developer   ~0042051

Last edited: 2015-02-14 00:50

View 3 revisions

Hmm, in your environment MM couldn't create the x64MMHelper.exe process for some reason. Win API function CreateProcess() returned false, I will add more debug messages to find why it doesn't work on your PC...

Ludek

2015-02-14 11:17

developer   ~0042052

Last edited: 2015-02-14 11:17

View 3 revisions

Peke, please use
FTP:/staff_files/forPeke/d_iPhone.dll
and generate new log. Thanks!

peke

2015-02-14 22:05

developer   ~0042053

Uploaded on FTP.

Ludek

2015-02-14 23:27

developer   ~0042054

Last edited: 2015-02-14 23:28

View 2 revisions

Fixed in 1731

Confirmed by Peke via IM (I posted him new DLL)

Ludek

2015-02-14 23:32

developer   ~0042055

Last edited: 2015-02-14 23:46

View 3 revisions

Also to be consistent with other processes (MediaMonkey.exe, MediaMonkeyVHelper.exe, MediaMonkeyCOM.exe, MediaMonkeyService.exe)
we should rename x64MmHelper.exe to MediaMonkey64helper.exe ?

But on the other hand it is currently confusing for users which EXE to run if they just want to launch the app, so maybe we should rather rename them all from MediaMonkey* to MM* ?
Entered as 0012590

Ludek

2015-02-14 23:53

developer   ~0042056

Renamed to MediaMonkey64Helper.exe in build 1730, entered 0012590 as lower priority issue

peke

2015-02-16 23:35

developer   ~0042080

Verified 1732