View Issue Details

IDProjectCategoryView StatusLast Update
0012383MediaMonkey (current)Synchronizationpublic2015-02-28 13:49
Reporterpeke 
PriorityimmediateSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version4.1.5 
Target Version4.1.6Fixed in Version4.1.6 
Summary0012383: d_USBMass1.dll: is outdated
DescriptionAs D_WDMD took over functionality of USBMASS it should be removed from MMW installation of 4.1.6 and Setup app should delete it on install due teh fact it interfere with WMDM and user of multiple devices have incorrect syncs as soon as he add second device to system.
Additional InformationPlugin is published under http://www.mediamonkey.com/addons/browse/item/usb-mass-storage-plug-in/
TagsNo tags attached.
Fixed in build1721

Relationships

parent of 0012386 assignedpeke MediaMonkey Addons d_USBMass: Backward compatibility for users that used plugin in previous versions 
related to 0005531 resolvedpeke MediaMonkey (current) USB MS Plugin: fails to delete old playlists 
Not all the children of this issue are yet resolved or closed.

Activities

peke

2014-11-23 20:47

developer   ~0041109

I had three sessions with two users that complained that after inserting second/third external HDD/FLASH disk one or all other vanishes.

All two issues solved by deleting USBMass plugin and let WMDM take over.

Ludek

2014-11-24 17:19

developer   ~0041126

I have already added this issue for MM5 as #12178

But you are probably true that we can remove it even for 4.1.6

Ludek

2014-11-25 00:30

developer   ~0041133

Last edited: 2014-11-25 00:30

View 2 revisions

Removed from the installer in build 4.1.6.1721

peke

2014-11-25 21:05

developer   ~0041147

Verified 1721

Ludek

2015-01-05 23:03

developer   ~0041588

Peke, there are some complaints / usecases that are no longer possible:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=78611

I missed the mapped drive issues previously, we should make d_USDMass.dll as standalone plugin/addon (MMIP) available to download here: http://www.mediamonkey.com/addons/browse/item/usb-mass-storage-devices/

Currently the plugin is presented there, but MM 4.1.5 install package is downloaded instead of the MMIP, could you create d_USBMass.MMIP and publish there?

peke

2015-01-06 17:30

developer   ~0041593

Last edited: 2015-01-06 17:35

View 4 revisions

Can you please just add simple check so that USBMass1.dll do not trigger on Removable drives that are handled by WMDM?

It should be fairly easy to add "IF (not Removable) OR (is Mapped) drive THEN" check.

Ludek

2015-01-07 13:15

developer   ~0041602

Last edited: 2015-01-07 13:16

View 3 revisions

Peke, can you clarify what do you mean?
Do you want to add the condition directly to d_USBMass.dll so that it cannot handle removable drives?
Which is the reason? I think that d_WMDM does not interferre with d_USBMass.dll until the device is manually mapped when configuring d_USBMass.dll, right?

If yes, then I think that we can publish d_USBMass.dll as is (just add it to separate MMIP) and post here: http://www.mediamonkey.com/addons/browse/item/usb-mass-storage-devices/

peke

2015-01-08 11:47

developer   ~0041613

Yes exactly, just plain condition so that USB Mass do not handle/detect Removable drives.

WMDM do not interfere with USBmass but WHEN USB Mass can handle some device then WMDM New device detected is not trigerred and the reason we removed plugin in first place.

I would like that we publish USBMass as separate plugin that will allow user to do manual settings and it should work only in that case no other cases where WMDM can handle the device.

Maybe we should rename d_USBMass1 to d_xDriveto avoid init/query handling prior to d_wmdm plugin?

Ludek

2015-01-08 20:45

developer   ~0041618

Last edited: 2015-01-08 20:47

View 3 revisions

I am not sure about htis, I think that if user manually configured USBmass for the given drive letter then he did it intentionally and wants USBmass to control the drive/device (overriding WMDM).

I think that publishing USBmass as separate addon will be enough for now.

peke

2015-01-08 23:28

developer   ~0041621

I agree but that interfere with other devices of same type that ocupy same drive letter making WMDM not trigger at all for any subsequential inserted device.

This is the case due the windows dynamically assigning drive letters to remote devices.

The only workarround is that if you use it for removable HDD you FIX drive letter to that device which will tell Windows to assign new letter for other inserted devices and make WMDM work.

Ludek

2015-01-13 10:28

developer   ~0041668

Last edited: 2015-01-13 10:31

View 3 revisions

I am not very keen on the change, I guess that assigning USBMass to a single drive letter can be desirable in some user scenarios. e.g. user wants to use single device profile for multiple HDD/memories/devices that occupies the single drive letter. Note that in Win 8 some external HDDs are recognized as removable instead of fixed.

I still think that publishing USBmass (as is) as separate MMIP here http://www.mediamonkey.com/addons/browse/item/usb-mass-storage-devices
will be enough.

Ludek

2015-02-16 22:04

developer   ~0042069

Last edited: 2015-02-16 22:05

View 2 revisions

The MMIP is uploaded:
FTP://!!!MMIP/dUSBMass.mmip

@Rusty, could you please publish it here: http://www.mediamonkey.com/addons/browse/item/usb-mass-storage-devices

peke

2015-02-16 23:14

developer   ~0042074

Corrected uninstall ini to prompt for restart and moved to correct folder

/MMW/addons/d_USBMass1/d_USBMass1_4.1.6.1720.mmip

Ludek

2015-02-17 16:15

developer   ~0042090

Last edited: 2015-02-17 16:16

View 2 revisions

ok, assigned to Rusty for publishing the Peke's version with icon and restart prompt on uninstall.

rusty

2015-02-19 03:53

administrator   ~0042125

Updated.

peke

2015-02-28 13:49

developer   ~0042223

Closing No more updates needed