View Issue Details

IDProjectCategoryView StatusLast Update
0012229MediaMonkey (current)Synchronizationpublic2015-09-25 18:06
ReporterLudek 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1.9Fixed in Version4.1.9 
Summary0012229: iOS8/9: iTunes is wiping out artwork when syncing apps
DescriptionSync some tracks using MediaMonkey to iPhone
As soon as I perform an app sync in iTunes, ALL artwork is wiped out.
After problem occurs, I can look at the "Get Info" applet in iTunes and it shows the artwork there.

So for some reason the iPhone no longer shows artwork synced by MediaMonkey
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=78067&p=396783#p396759
http://www.mediamonkey.com/forum/viewtopic.php?f=12&t=77424&p=396784#p396691
TagsNo tags attached.
Fixed in build1762

Activities

Ludek

2014-10-15 19:07

developer   ~0040772

Fixed in 1718.

Ludek

2014-10-19 21:03

developer   ~0040789

Closed, confirmed also here: http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=78067#p397009

Ludek

2015-04-08 13:10

developer   ~0042409

Last edited: 2015-04-08 14:18

View 4 revisions

Re-opened, this issue is re-occuring with the iOS 8.2 and the newest iTunes
iTunes app sync still wipes artwork for some files

Ludek

2015-04-08 14:17

developer   ~0042410

Fixed in 4.1.7.1739

Ludek

2015-04-08 18:54

developer   ~0042412

Last edited: 2015-04-08 19:05

View 4 revisions

Re-opened, there is still a problem, iTunes wipes artwork for some files (5% in my case). I haven't found a key so far, but it happens during restoring of device backup (during sync).
I don't know why iTunes backups the music files metadata at all (and does not restore them all).

peke

2015-04-16 00:00

developer   ~0042434

I tested on Devices <v8 iOS and could not replicate.

Ludek

2015-09-03 17:40

developer   ~0042895

Fixed in 4.1.9.1757

rusty

2015-09-24 17:14

administrator   ~0042978

Tested in build 1761 and I'm still able to replicate the loss of album art as described at http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=81455&start=15
In my case manual synchronization was enabled for everything. Then when I clicked 'sync' to sync apps/app data, iTunes indicated that artwork was being synced for certain music files.

The net result is that iTunes deleted AA only for tracks that don't have it stored to tags (i.e. AA that is stored to track tags doesn't get deleted).

The unfortunate thing is that resyncing with MMW doesn't fix the problem. The only solution is to delete the tracks and resync them :-(

Ludek

2015-09-25 13:00

developer   ~0042988

Last edited: 2015-09-25 15:03

View 5 revisions

iTunes wipes the artwork during automatic backup. The problem is that automatic backup during sync cannot be disabled, the only choices are to backup to iCloud or to Computer.
But in both cases iTunes backups and restores also all music files for some reason (even if '[ ] Synchronize music' checkbox is unchecked).

You can see that during iTunes sync, when all music files are getting lost their artwork for a while and then the artwork is re-added back by iTunes.

As Rusty found the artwork is added back only for files with artwork embedded in file tags. I've spent a lot of time to figure out how to tweak it and the only that I found is that iTunes simply expects at least one artwork in file tag otherwise it wipes it.

I confirmed my speculations by following experiment:
1) added 3 artworks to a file, the first two artworks were just linked and the third was in file tag.
2) Synced to iPhone, only the first (linked) artwork was synced as expected and shown in the iPhone's My Music app
3) Performed iTunes sync
=> artwork was still there

4) repeated the steps 1,2,3 again, but deleted the third artwork (embedded) so there wasn't any artwork in file tag
=> artwork was wiped

So the conclusion is that iTunes expects at least one artwork in file tag.

Therefore I've hidden the artwork config for iPhones (Device -> Options -> Tagging) and artwork is now always embedded for all files during sync.

This resolved the issue.

Fixed in build 1762

Test note: Files needs to be re-synced (either deleted and auto-synced OR replaced by using Send to -> iPhone)

peke

2015-09-25 16:58

developer   ~0042994

Verified 1762 in Touch 4G and files on device

rusty

2015-09-25 18:05

administrator   ~0042996

Verified 1762