View Issue Details

IDProjectCategoryView StatusLast Update
0012205MediaMonkey (current)Synchronizationpublic2018-10-26 12:09
ReporterLudek 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionreopened 
Product Version4.0.7 
Target Version4.1.24Fixed in Version4.1.6 
Summary0012205: Two distinct SD cards are recognized as same device profile
DescriptionIf one switches distinct SD cards in one card holder, there are still seen as the same device by MediaMonkey. This results in inability to sync distinct SD cards differently.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=12&t=77721
TagsNo tags attached.
Fixed in build1720

Relationships

parent of 0012820 closedLudek MediaMonkey (current) StorageInfo.xml is created even if the device has not been ever synced 
related to 0012196 closedmarek MediaMonkey for Android Duplicate profiles in MMW can occur 
related to 0012182 resolvedmarek MediaMonkey for Android DeviceConfig.xml not found during Wifi sync 
related to 0012439 assignedjiri MediaMonkey (current) Import/Export: Ability to migrate whole Sync Settings to another device profile 
related to 0012794 resolvedLudek MediaMonkey (current) HTC One: USB device profiles for 'SD Card' and 'Internal storage' are swapped sometimes (when MMA is not installed) 
related to 0013028 closedLudek MediaMonkey (current) Sync: Multiple USB Thumb Drives of same type get same profile 
related to 0013119 closedLudek MediaMonkey (current) Duplicate profiles can occur due to deletion of storageInfo.xml 

Activities

Ludek

2014-11-17 17:00

developer   ~0041042

Last edited: 2014-11-17 17:00

View 2 revisions

This would be good to fix for 4.1.6

e.g. WMP handle this correctly (different SD cards in single card slot are recognized as different profile)

Ludek

2014-11-17 17:06

developer   ~0041044

Last edited: 2014-11-18 11:25

View 3 revisions

The easiest solution should be to store an info file to the SD cards (something like StorageInfo.xml that we use in case of Android's SD cards).

The same way uses WMP (it stores WMPInfo.xml file with the key to the root of the SD Card)

Ludek

2014-11-18 13:58

developer   ~0041050

This longstanding issue is fixed in build 4.1.6.1720 and merged into 5.0

peke

2014-11-24 03:09

developer   ~0041115

Verified 1720

I wonder why don't we just add partition Serial Number to MMW like for Scanned media? and not save anything on card itself?

Ludek

2014-11-24 17:13

developer   ~0041125

Last edited: 2014-11-24 19:58

View 4 revisions

My SD card reader has only one SN despite the inserted SD card. Therefore we need to use the info file with generated key. The same approach uses Windows Media Player ( WMPInfo.xml file )

peke

2014-11-26 01:46

developer   ~0041160

Last edited: 2014-11-26 01:51

View 2 revisions

Verified 1720

That is strange as it is very very rare to have Partittion SN same on all cards no matter which one you insert Are you sure that CMD "DIR" show same serial for all cards you have?

If that is the case maybe we should consider something to change in MM5 and use different criterias for locking locations in Library?

Ludek

2014-11-26 10:13

developer   ~0041161

Last edited: 2014-11-26 10:14

View 2 revisions

The main advantage of using the info StorageInfo.xml file approach is that it doesn't matter in which device the SD card resides. e.g. I can switch SD card synced via a card holder (with assigned drive letter) and then put the same SD card to a MTP device. Thanks to the info file it will match the profile despite the device used. I believe that this is one of the main reasons why WMP uses the same approach.

peke

2014-11-26 23:35

developer   ~0041178

You are right I didn't consider that inserting card to device will use/pull info from file. Closing

Ludek

2018-10-24 12:23

developer   ~0051430

Last edited: 2018-10-24 12:46

View 3 revisions

Re-opened, as found by user here: http://www.mediamonkey.com/forum/viewtopic.php?f=30&t=91709
The storageInfo.xml is written just upon the first sync, but just setting up the profile MM5 (including name, file locations, auto-sync) doesn't create the file and thus the profile mismatch can appear.
i.e. it should be created immediately once user changes the sync settings.

Ludek

2018-10-24 12:45

developer   ~0051431

Last edited: 2018-10-26 12:09

View 2 revisions

Fixed in 4.1.24.1882 and merged to 5.0.0.2131