View Issue Details

IDProjectCategoryView StatusLast Update
0012063MediaMonkey (current)Properties/Auto-Toolspublic2015-04-21 19:26
Reporterpeke Assigned To 
PriorityimmediateSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version4.1.2 
Target Version4.1.6Fixed in Version4.1.7 
Summary0012063: Get Info/Buy: Providers do not have correct Icons
DescriptionMMW should Cache providers favicons.ico and use them in "Get Info/Buy"

Amazon: http://www.amazon.com/favicon.ico
HD Tracks: http://www.hdtracks.com/favicon.ico
YouTube: http://www.youtube.com/favicon.ico
Google: http://www.google.com/favicon.ico
Wikipedia: http://www.wikipedia.org/favicon.ico
CD Universe http://www.cduniverse.com/favicon.ico
Library: MMW Default APP icon

This should be done on install of MMW only once or if favicon.ico is non existing for that provider.
Additional InformationKWB-733-60497 (regression)
TagsNo tags attached.
Fixed in build1740

Relationships

parent of 0012818 closedLudek Favicons folder is shown as Skin in List 

Activities

Ludek

2014-05-27 11:00

developer   ~0040244

Fixed in build 4.1.2.1706

The icons are cached on background after MM start into temporary directory (MMCache_icons folder) and are re-cached only once deleted from the temp. dir.
So they can be missing for a few seconds on first time run (once they are being cached on the background).

peke

2014-06-03 23:44

developer   ~0040261

Others verified 1706.

Library Icon is Missing it should use existing MMW icon of Entire Library Tree.

peke

2015-02-24 05:30

developer   ~0042172

Confirmed regression with Zvezdan also.

Socket error Keeps background icon download active which results in Slow MMW closing.

peke

2015-02-24 13:23

developer   ~0042173

Last edited: 2015-02-24 13:46

View 3 revisions

2. As Zvezdan Suggested we should move "MMCache_icons" to Roaming\MediaMonkey

Later this folder than can be used to Cache Icons from Podcast/Subscription sites like http://www.npr.org/favicon.ico

Ludek

2015-02-25 11:54

developer   ~0042177

Last edited: 2015-02-25 11:55

View 2 revisions

Fixed the cache issues in build 1734

Icons are now cached to /AppData/MediaMonkey/favicons/ or /Portable/favicons/ and are cached only when the favicons directory does not exist, so usually on first time run only.

peke

2015-02-26 23:20

developer   ~0042204

Verified 1734

Will ask Zvezdan for confirmation.

peke

2015-02-27 21:36

developer   ~0042214

Reopen,
Looks like if there is socket error on retriving icons MMW still tries to fet them instead of just abandon till next startup?

Log is uploaded to FTP

Ludek

2015-02-27 22:00

developer   ~0042215

Last edited: 2015-02-27 22:06

View 3 revisions

As discussed over IM with Peke,

Zvezdan cannot even download them using IE6 (probably a firewall issue ?)
The good news is that in 4.1.6.1734 MMW tries to download them just once (once the internet connection is available), so MM won't try it on each start repeatedly

But for 4.1.7 we should lower the the TCP timeout (in the Zvezdan log it takes too long before the Socket Error # 11001 appears, this slows down MMW closing)

Ludek

2015-02-27 22:21

developer   ~0042216

Last edited: 2015-03-02 21:02

View 3 revisions

Fixed in 4.1.6.1736

The timeout for each favicon lowered to 5 seconds + added download interruption when app is terminating

peke

2015-03-03 00:00

developer   ~0042238

Verified 1736

peke

2015-03-28 21:43

developer   ~0042363

Still not working satisfying.

I got impression that only in cse that MMW is closed within 20 Seconds after startup we will have delay of 20 seconds where MMW will iterupt download and will not try again. But from last description it looks like whenever MMW is closed on [x] there is 20 Sec delay no matter how long it is open.

Can you clarify?

Again No delay if icons are manually put in right folder.

Ludek

2015-03-30 09:55

developer   ~0042364

Last edited: 2015-03-30 09:56

View 2 revisions

There is no 20 seconds delay, as I've written in 0012063:0042177

Icons are now cached to /AppData/MediaMonkey/favicons/ or /Portable/favicons/ and are cached only when the favicons directory does not exist, so usually on first time run only.

If you mean the Zvezdan issue (where no icon is downloaded due to a firewall issue) that I guess it should work to stop the downloading (becuase the favicon diretory is created), or it isn't the case for him?

peke

2015-04-14 03:47

developer   ~0042427

It happen to me when I got "socket error code 10061" in which case there is exactly 25 Seconds delay on MMW exit.

peke

2015-04-16 22:05

developer   ~0042441

Can you include Icons in Installer?

Ludek

2015-04-19 17:52

developer   ~0042446

Last edited: 2015-04-19 17:54

View 2 revisions

Fixed in 4.1.7.1740

Icons are now bundled within the installer (and not downloaded at all).

peke

2015-04-21 19:26

developer   ~0042455

Verified 1740