View Issue Details

IDProjectCategoryView StatusLast Update
0011905MediaMonkey (current)Otherpublic2014-02-27 12:06
Reportermambo-eiji 
PriorityimmediateSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
PlatformOSAll WindowsOS Version
Product Version4.0.4 
Target VersionFixed in Version 
Summary0011905: [Specification Confirmation] About Download Timeout
DescriptionThe customer asked about the specification of music.jp PLAY download timeout. This is a rather urgent question.
When a song is downloaded from the server, how much time does it wait to become a timout?
A quick look into Rick's script suggested that he is not setting any value for download timeout in it. So this must be a default timeout value of the downloader of mediamonkey.
Is it 180 seconds as suggested in the issue:

http://www.ventismedia.com/mantis/view.php?id=3329

?
TagsNo tags attached.
Fixed in build

Relationships

related to 0003360 closedLudek Use single internet access library instead of TIE + Indy 

Activities

Ludek

2014-02-27 12:00

developer   ~0039728

Last edited: 2014-02-27 12:05

View 4 revisions

We no longer use TIE starting from MM4, we use Indy (http://www.indyproject.org/), more about the reasons here: 0003360:0020068

And the timeout used for downloading files is 30 seconds.