View Issue Details

IDProjectCategoryView StatusLast Update
0011830MediaMonkey for AndroidUPnP / Castingpublic2016-05-30 16:36
Reporterlowlander 
PriorityurgentSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.2.0 
Target Version1.2.0Fixed in Version1.2.0 
Summary0011830: Add Chromecast support
DescriptionGoogle has release the Chromecast SDK. It would be nice if:
1) Users can play from MMA to Chromecast. Our existing UPnP renderer UI should work fine. e.g. :
a) When the user clicks the 'renderer' button, individual chromecast and chromecast groups are presented to the user to choose.
b) In order to distinguish UPnP vs Chromecast renderers, there should be some sort of indicator next to each entry in the list of rendeders

Note:
- I'm not sure what audio formats are supported by the Chromecast, but users expect that any track that's playable in MMA, should also be playable via the chromecast.
- Audio support is much higher priority than Video support

2) Users can run MMA on Chromecast (e.g. a party mode using MMA as a controller). Not a high priority.
Steps To Reproducehttp://chrome.blogspot.ca/2014/02/chromecast-is-now-open-to-developers.html
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=20&t=75153
http://www.mediamonkey.com/forum/viewtopic.php?f=20&t=74589&p=378814p378814
http://www.mediamonkey.com/forum/viewtopic.php?p=385287#p385287
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=78395
TagsNo tags attached.
Fixed in build588

Relationships

related to 0013165 resolvedLudek MediaMonkey (current) MMW --> MMA --> Chromecast rendering fails 
related to 0013315 resolvedmartin MediaMonkey for Android Compatibility with Blackberry / Amazon devices 

Activities

marek

2014-10-30 08:45

developer   ~0040840

I think that this can be postponed. We are now trying new implementation of players. So it will be probably better to beta test it before adding new type of players to play remotely. I don't even have this device.

Btw. do You think that it is till worth when Google came with Android TV that will probably replace chromecast that wasn't so popular because of it's limited functionality.

rusty

2014-11-06 20:56

administrator   ~0040909

Last edited: 2014-11-20 21:23

View 2 revisions

Chromecast has been the top selling electronics device on Amazon for the past year. Estimates of 4m units in 2013! See: http://www.dailytech.com/Report+Apple+TV+Fell+Behind+Chromecast+Roku+in+2013+Sales/article36193.htm

Also, it's supported in Google Play.

BUT, non-app-specific streaming is working well, so we can defer this, and collect input.

EDIT: non-app-specific streaming only works on Nexus devices ATM, so we may want to triage this up.

martin

2016-02-29 16:51

developer   ~0044216

Rusty please register our application:
https://developers.google.com/cast/docs/registration

I need applicationId to create Beta build (applicationId is required by castcompanionlibrary ).

In step 3 choose "Styled Media Receiver"
The field "Skin URL" leave empty (we can specify our css file later, for now we can use default style) .

leave unchecked the "Supports Google Cast Guest mode"
and check "Supports casting to audio-only devices"

Thanks

martin

2016-03-03 17:27

developer   ~0044237

Last edited: 2016-03-03 17:38

View 2 revisions

Fixed in build 1.2.0.581

martin

2016-03-03 17:37

developer   ~0044238

Last edited: 2016-03-03 21:35

View 2 revisions

Ludek, please, after new build 481 will be created, take a look on case when MMA try to play tracks from MMW library to chromecast, I mean:

MMW(as library) -> MMA(as controler) -> Chromecast

It seems that issue is on MMW side, because it's working when I use Windows
Media Player as library. Working:

WMP(as library) -> MMA(as controler) -> Chromecast
MMW(as library) -> MMA(as controler) -> UPnP renderer

EDIT by Rusty: Tracking at 0013165

martin

2016-03-17 17:11

developer   ~0044286

Fixed in build 1.2.0.0582

martin

2016-03-19 13:42

developer   ~0044298

Added cast button to tracklist and home screen view
Stop button doesn't work on casting - fixed
Unified and improved Chromecast and Upnp metadata
also fixed 0013169

Fixed in build 1.2.0.0585

rusty

2016-03-22 20:28

administrator   ~0044310

Last edited: 2016-03-22 22:59

View 3 revisions

Tested build 585, it's working well. A few minor issues:
1) Even though I have MediaMonkey Pro, it still gives me a warning re. a 30-min limit for casting. This shouldn't appear for Pro users.

2) The casting icon shouldn't appear at the top of the screen always--it takes up too much real estate. I would suggest:
- It can appear on the Global menu
- It can appear on the Now Playing header when activated

3) OGG tracks don't cast (even though they play without a problem on a Nexus 5).

4) Tracks that don't cast (OGG or corrupted MP3) cause playback to stop on the problematic track. What should happen instead is that if playback doesn't work correctly, MMA should advance to the next track.

5) When MMA reaches the last track on the NP list, if the user presses 'Next' to advance to the end of the playlist, then MMA continues playing the last track even though the NP track is shown as the first track in the playlist. It should just stop playing and show the first track.

martin

2016-03-25 00:17

developer   ~0044330

Last edited: 2016-03-26 14:38

View 2 revisions

re 2)
I agree, that when we have "shuffle all" at the top, then we should hide "casting icon" to Global menu, but on the Now Playing header it should be visible every time.
In all cases the "casting" icon is visible only when some chromecast or renderer is available.

  
6) Fixed NP title (on player changed)
7) Empty view in CastConnectionDialog
8) Added connecting state for upnp (unified state machine with chromecast)"
9) Fixed album arts for chromecast and fixed streaming default album art

Fixed in build 1.2.0.586

rusty

2016-03-28 20:43

administrator   ~0044333

Tested 586:
1) Verified--warning no longer appears on Pro device.

2) Agreed, BUT--if the cast icon appears in the NP header shouldn't it appear in both the AA and list views? Currently it only appears in the AA view.

3) Verified--ogg plays correctly now (But there's a problem with Flac files on Samsung devices--see issue 10).
4) Verified--problematic tracks skip.
5) Verified--handling of last track in NP list is correct.
6) Verified
7) Verified
8) Verified
9) Verified

10) Flac files fail to Cast on a Samsung Tab 8.4 even though they play fine locally (note: the device is running Android 4.4.2 and the tracks are playing from an SD card. A samsung S5 running Android 5 has no problem playing the same flac files.)

11) On a Samsung Tab 8.4 running Android 4.4.2, upon attempting to adjust the volume while MMA is in focus, the Media volume is adjusted instead of the Chromecast volume.

Tapping on the Volume 'settings' causes the Chromecast volume to appear (so the user can edit the volume from there) however, attempts to adjust it don't work correctly:
- Sometimes sliding the volume to the right causes the volume to change, but the indicator 'bounces' back to its original position
- Sometimes sliding or tapping the volume to set it has no effect

I'm not sure whether these are MMA problems that are particular to Android 4.4.2, or whether these problems are Android 4.4.2 problems (note: neither the incorrect volume adjustment nor the misbehaving volume slider problem occurs on a Samsung S5 mini running Android 5 or on a Nexus 5 running Android 6).

11b) Occasionally when adjusting the media volume (this may be coincidence), a message appears indicating that "the connection to the cast devices was temporarily lost". When this occurs, the chromecast volume changes to '0' and the bug described in 12a prevents the user from increasing the volume. Unless the user is playing very close attention, it appears as if the chromecast isn't working at all, since its volume has been set to 0.

12) Minor issue: On a chromecast video, regular transitions work correctly (i.e. the album art image appears at the left margin and the track loads), but if the user clicks 'Next' to advance to the next track, then the AA image/Metadata briefly flash in the middle of the screen, then re-appears at the left margin of the screen as the track loads.

13) Minor issue: If playback is paused and the user initiates casting --> playback starts by itself. I would expect that as with bluetooth, just initiating the connection shouldn't cause playback to start.

martin

2016-03-31 08:42

developer   ~0044357

10) Flac files fail on 4.4.2 - fixed
- also fixed ogg/flac files playback on some Upnp renderers
11830: Add Chromecast support
11) volume control - implemented
12) It seems that it is normal behavior for default "Styled Media Receiver" (same behavior with Universal music player from Google). Google music has custom receiver so it doesn't occur with that.
13) auto play - only when media is already playing
14) Fixed playback Notification on chromecast disconnected

Fixed in build Build 1.2.0.0587

rusty

2016-04-01 10:49

administrator   ~0044366

2) This is still open. if the cast icon appears in the NP header shouldn't it appear in both the AA and list views? Currently it only appears in the AA view.

10) verified

11) The volume now controls correctly via the up/down buttons, however the volume type doesn't display! ie when mma adjusts her casting volume it just shows a toast pop-up but when it adjusts local volume it shows the volume control

12) OK

13) verified

14) The message should be changed to
Connection to cast device has been lost

martin

2016-04-01 13:34

developer   ~0044369

re 14) fixed

re 11)

a) we can handle cast volume by ourselves (used processing from CastCompanionLibrary) with toast message only - working on all devices

b) or we can trust OS processing, but it's seems to be working
well only on Android >=5 (Api >= 21) and I hope it's not device specific.
(Chromecast volume is adjust while playing only, not on pause)

c) I tried to show OS volume dialog and handle volume ourselfs, but os volume dialog is stuttering and also visible while playing only.

So I suggest b)
for API < 21 our volume control with toast (or we can implement nicer dialog)
for API >= 21 use OS control with OS volume dialog (not handling on MMA side)

or keep a) as is

rusty

2016-04-01 13:45

administrator   ~0044371

Re. 11) b probably makes most sense.

martin

2016-04-01 13:50

developer   ~0044372

Fixed in build 1.2.0.0588

peke

2016-05-02 00:03

developer   ~0044529

Adding Chromecast make MMA dependent to newer Google Play Services.

I have found that installing Google play services 8.7.03 works with MMA 1.2.0

We should note that on App description.

martin

2016-05-02 14:48

developer   ~0044531

Yes chromecast use companionlibrary:ccl:2.8.3, which depends on
google-play-services_lib library from the Android SDK (at least version 8.3+)
https://github.com/googlecast/CastCompanionLibrary-android

rusty

2016-05-20 16:37

administrator   ~0044677

http://www.mediamonkey.com/support/index.php?/Knowledgebase/Article/View/242/23/casting-to-google-cast-devices-doesnt-work