View Issue Details

IDProjectCategoryView StatusLast Update
0011619MediaMonkey for AndroidPlaybackpublic2014-09-29 15:21
Reporterrusty Assigned To 
PriorityhighSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version1.0.4 
Target Version1.1.0Fixed in Version1.1.0 
Summary0011619: Disable 'Touch sounds' when active
DescriptionAndroid has a setting to enable/disable 'Touch Sounds', and if they're enabled, it results in audio artifacts while playing Audio over bluetooth.

It would probably make sense to disable Touch sounds by default, when the MMA screen is active. e.g.

[ ] Disable touch sounds
Additional InformationRaised at:
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=74755
TagsNo tags attached.
Fixed in build320

Activities

jiri

2014-01-13 12:33

administrator   ~0039203

Rusty, my understanding is that you mean to _not_ include any configuration and simply always disable Touch Sounds, right?

rusty

2014-01-13 15:32

administrator   ~0039206

Last edited: 2014-01-14 14:59

View 2 revisions

Actually, I was was trying to suggest that MMA should disable touch sounds when the option to do so is enabled. e.g.:

[x] Disable 'Touch sounds'
Disable Android's Touch Sounds while playing

Would cause Touch sounds to be disabled globally (for MMA and for other apps) whenever MMA is playing (some users might want them to be disabled when MMA is _running_ even if it's not playing, but that might be too aggressive).

If you prefer to go without a UI, MMA could disable touch sounds only when both of the following are true:
- MMA is playing something
- The user is trying to interact with the MMA interface

jiri

2014-01-14 08:35

administrator   ~0039210

Ok, so let's go with the UI, enabled by default:

[x] Disable 'Touch sounds'
Disable Android's Touch Sounds while music is playing

rusty

2014-01-14 15:01

administrator   ~0039214

I've made a small change:

Disable Android's Touch Sounds while music is playing
-->
Disable Android's Touch Sounds while playing

(since the setting isn't really specific to music)

martin

2014-09-29 15:21

developer   ~0040639

Fixed in build 333.