View Issue Details

IDProjectCategoryView StatusLast Update
0011522MediaMonkey (current)Properties/Auto-Toolspublic2017-06-22 01:05
ReporterLudek Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1.17Fixed in Version4.1.17 
Summary0011522: Artwork lookup no longer works
DescriptionAs confirmed by failed DUnit test:
Scripting -> TTestLookup -> TestArtworkScript
and also confirmed by user here:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=74544

Artwork lookup functionality has broken few days ago.
Tagswiki
Fixed in build1838

Relationships

related to 0011284 closedmartin MediaMonkey for Android Album Art searcher 

Activities

Ludek

2013-11-27 14:13

developer   ~0038399

Last edited: 2013-11-28 15:07

View 8 revisions

Fixed in build 1673.

Note that it was broken due to changes on google side.

I think we should distribute the aaSearch.js file as separate MMW addon, this way we can modify it accordingly anytime there is a server change or add alternate servers (like Yahoo etc.)

@Peke, we should also let scripters know about the ssSearch.js and lyricsSearch.js files installed to MM/Scripts folder. Scripters can modify them to add/remove alternate servers and distribute them as an addon to override the lookup functionality.
Could you let them know? We should also add it to our WiKi.

peke

2013-12-22 19:56

developer   ~0038977

Verified 1681 and 1682

Left resolved till Wiki page is created.

Ludek

2016-04-19 16:30

developer   ~0044462

Last edited: 2016-04-19 21:18

View 2 revisions

Re-opened,
artwork lookup doesn't work again.

MM4 -> DUnit -> TTestLookup -> TestArtworkScript --> fails
MM5 -> QUnit -> Metadata Loopkup: artwork lookup --> fails
+ reported by user WWB-794-95285

Ludek

2016-04-20 10:05

developer   ~0044468

Fixed in build 1788.

peke

2016-04-21 23:49

developer   ~0044483

Verified 1788

Ludek

2017-06-12 09:55

developer   ~0048124

Re-opened. Artwork lookup no longer works again.

michal

2017-06-12 10:19

developer   ~0048128

Fixed in build 1838.

peke

2017-06-22 01:05

developer   ~0048215

Verified 1838