View Issue Details

IDProjectCategoryView StatusLast Update
0011406MediaMonkey (current)Framework: Scripts/Extensionspublic2013-10-30 15:28
ReporterLudek Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1Fixed in Version4.1 
Summary0011406: MM 4.1 does not work with d_itunes4 (iTunes MediaMonkey Plugin)
DescriptionDownload iTunes MediaMonkey Plugin 4.0.4.2438 ( http://www.mediamonkey.com/addons/browse/item/device-plugin-for-itunes/ )
and try to sync with iTunes
=> several errors reported and the sync fails.

Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=74139
TagsNo tags attached.
Fixed in build1668

Activities

Ludek

2013-10-23 13:44

developer   ~0038017

Fixed in build 1668.

Neverthless there is still an issue, it seems that DEVICE_NotifyPlaylist in d_iTunes4.dll damages MM memory structures and potentional AV appears.
I workarounded it, but this should be fixed by the plugin developer.

peke

2013-10-24 15:55

developer   ~0038035

Verified 1668

Ludek

2013-10-30 15:28

developer   ~0038114

Removed the workaround of stack corruption caused by d_itunes4 in build 1669, because Mark has fixed it (as confirmed by the new DLL that he posted me):
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=74139#p376846