View Issue Details

IDProjectCategoryView StatusLast Update
0011022MediaMonkey for Android[All Projects] Generalpublic2016-12-21 09:36
Reporterpeke 
PriorityurgentSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version1.0.4 
Target Version1.3.0Fixed in Version1.3.0 
Summary0011022: Track Properties: Additional properties should be viewable
DescriptionWhen viewing/editing track properties it would be useful to show other properties:
- Volume index
- # played / last played
- bitrate
- filetype/codec


In addition, given the prevalence of Android tablets, any properties that appear in the Properties view should be configurable for display in list views.
Additional InformationMore requests for additional fields/associated views:
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=74715
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=74734
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=78658
Year: http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=78890
Year in NP: http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=80464
TagsNo tags attached.
Fixed in build650

Relationships

related to 0011293 feedbackrusty MediaMonkey for Android Add Sorting to views displaying tracks 
related to 0012002 feedbackrusty MediaMonkey for Android Classical Music views are overly limited 
related to 0013430 closedLudek MediaMonkey (current) Change default for Level Playback / Sync volume from "per Album" to "per Track" 

Activities

rusty

2016-06-02 15:12

administrator   ~0044842

I would suggest that in 1.2.1 MMA should display almost all of the non-editable properties that are contained within the DB, since this should require little work, and could be quite beneficial both for users and for debugging purposes (e.g. play count / skip count).

Can you provide me with a list of items that could be added and I can propose how to lay them out?

martin

2016-06-10 19:44

developer   ~0044932

Remaining items:
size,
mime_type
track //order in album,
last_time_played,
playcount //already displayed for local tracks
skipcount //already displayed for local tracks
volume_leveling,
lyrics // for audio tracks,
resolution //for video


Lyrics should be displayed in another tab in properties, I will think about it, whether this shouldn't be included rather to 2.0. with new UI changes.
Other items can be included to 1.2.1 without issue. Should I include all of them?

rusty

2016-06-14 20:36

administrator   ~0044949

Last edited: 2016-06-14 20:38

View 2 revisions

So assuming that play counter, skip counter, leveling are editable and will sync correctly, the way that this could work is:
(at the top next to the image)
Path:
Length:
Size:

(below Release date)
Leveling:
Track: _xx_ dB, Album: _xx_ dB
Play Counter: _xx_
Skip Counter: _xx_

Last played: date/time


If editing play/skip counters and/or leveling values will cause problems then we could use the following layout:

(at the top, next to the image)
Path:
Length:
Size:

(below Release date)
Details:
Last played: date-time
Play counter: xx
Skip counter: xx
Leveling: xx dB

As far as lyrics, I'll leave that to you. My feeling is that it's best to leave that for now since the edit functionality should be integrated with the lookup functionality, and that might be a bit complicated.

marek

2016-06-14 22:18

developer   ~0044950

Please note that these new values are not stored to modification table. So it should be stored there so it can be synced back to MMW. It has to be probably implemented on MMW side too.

martin

2016-07-21 14:36

developer   ~0045174

For Ludek:
New item "volume_leveling" is added to modification table, but MMW ignores this item yet.
Example of database with this modification is on ftp in "/staff_files/forLudek/11022".
Rest of items are already storing well.

For Rusty:
On other hand Track leveling cannot be modified directly on MMW side, but only by analyzer, right?
Should be really it editable from MMA directly?
What should be max and min value? (-100dB, +100dB)?

If "volume_leveling" should be editable from MMA, then please reassign this issue to Ludek. Thanks.

rusty

2016-07-28 05:33

administrator   ~0045244

Volume leveling values _are_ editable in MMW. Re. valid values, sure your proposal is fine (though I've rarely seen values outside the range of -20 to +20).

Re-assigning to ludek as requested.

Ludek

2016-07-28 21:17

developer   ~0045246

Last edited: 2016-07-28 21:19

View 3 revisions

Note that in MMW you can edit the volume level values only in file-listing via F2 key (and not in Properties). This is probably why Martin found it as non-editable in MMW.

The problem with bi-di sync of volume level value currently is that in MMW there are two values for volume leveling: "per album" and "per track".
This can be configured in Tools > Options > Volume Leveling

MMW sends to MMA only the "used" volume level values and by default it is "per Album", so it sends same "album level" value for all album tracks.

Because MMA hasn't this "per Album" criteria and it is always "per track" than I guess that the backward sync of this value doesn't make much sense.

We would need either:
a) add "per album" and "per track" volume leveling to MMA
b) sync only "per track" value, but in that case it wouldn't have impact in MMW's default config (because the default is "per album")
c) leave it as is, i.e. sync the configured and "used" volume level value only from MMW -> MMA and not from MMA -> MMW

I guess that
a) would unnecessary complicate UI and other stuff in MMA
b) doesn't make sense in default config and would be rather unexpected
c) makes most sense for now?

rusty

2016-07-28 22:06

administrator   ~0045247

The correct solution would be to implement a). However, I don't consider this to be that high a priority, so for now we should just leave as is (option c), but display the volume leveling value in a non-editable fashion.

peke

2016-07-28 22:17

developer   ~0045248

Last edited: 2016-07-28 22:30

View 4 revisions

I agree on c) to be best practice currently.

But there could be another solution I think:
d) Add Volume Level Type in Profile sent from MMW, keep things as is and show Volume leveling with Suffix from Profile (read only)

That way on Next Sync if MMW settings has changed it can be easily corrected, and in case of volume differences User will know if there is volume level, which one is used and compare with MMW playback.

MMA UI will show based on current state:
No Type in profile - Volume Index: xx.xx db
If Type exist in Profile - Volume Index (Per Album): xx.xx db

FYI many users (me included) with with various types of music usually change into Per track due the fact that Album Gain on Classical tracks and regular music tracks differs so much (if Per Album setting is used, where Per track play them correctly).

rusty

2016-07-28 22:35

administrator   ~0045249

You make a really good point about the fact that Track gain usually makes more sense than album gain (even in MMW), since the only time Album Gain actually makes sense is if the user plays the Album in one shot. The problem is that afaik MMW doesn't 'know' if an entire Album is being played, and so it plays with album leveling even if the tracks that are being played are from different albums.

This makes me wonder if perhaps it would be better to:
a) change the default playback behavior in MMW to track level volume leveling on playback
b) make synchronization work based on the playback rules (i.e. if the user sets a default of track leveling, then MMW should sync the track-level values rather than the Album-level volues.

peke

2016-07-28 23:16

developer   ~0045250

Last edited: 2016-07-29 01:47

View 4 revisions

I agree.

Currently best would be:

MMW
---
- Leave sync as is and add volume playback rule into Sync profile so that MMA know active setting and where Leveling index come from. Due the fact it will not change much in terms of design and functionality
- Send Metadata update in case Volume playback rule has been changed and update profile as proposed in b) of 0011022:0045249
- Ability to trigger leveling info update change on WiFi Sync (Lower priority)

MM5
---
- All above MMW Plus
- As suggested in 0011022:0045249 change default to per Track instead of per Album

MMA
---
- Add Volume leveling Type in profile settings
- Add Volume leveling as read only in track properties and show it as proposed in 0011022:0045248 which will clearly tell user what volume index value is used
- Add ability to change volume leveling Type in Options (Playback) so that on next sync MMW can send correct metadata (Lower priority)

Ludek

2016-07-29 09:20

developer   ~0045252

Last edited: 2016-07-29 09:22

View 4 revisions

Re 0011022:0045249
a) I also think that changing the default in MMW makes sense, tracked as 0013430
b) It currently works this way, i.e. the values configured in options are used to sync, i.e. is automatically fulfilled by changing the default 0013430

Re the solution used, it seems that we all agreed that c) should be used for now.
The others (a,d) and "volume level per sync profile" suggested by Peke are rather lower priority future possibilities.

Assigned back to Martin to display the volume leveling value in a non-editable fashion as suggested by Rusty in 0011022:0045247
IMHO volume level can remain editable in MMA -- although I guess that users will hardly to edit the values manually (until they are somehow far from correct)

martin

2016-07-29 12:02

developer   ~0045257

Ok, volume leveling displyed in a non-editable fashion.

Fixed in build 1.2.1.650

peke

2016-12-21 09:36

developer   ~0046671

Verified 657