View Issue Details

IDProjectCategoryView StatusLast Update
0010610MediaMonkey (current)Synchronizationpublic2013-03-15 03:39
Reporterlowlander Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1Fixed in Version4.1 
Summary0010610: iOS5+ Sync removes files from Playlist in MediaMonkey
DescriptionTested with iPod Touch, iOS Sync removes files from Playlist in MediaMonkey.
Steps To Reproduce1) Create Playlist with some files
2) Set it to sync to device in Device Profile
3) Connect iOS device
4) Initiate Auto-Sync
5) On finish add more files to Playlist
6) Initiate Auto-Sync again

The Playlist now has the files added in step 5 removed. I've also managed to reproduce with a disconnect between step 5 and 6. The key may be to add files to the Playlist after Auto-Sync, but with the iOS still attached.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=12&t=70436
TagsNo tags attached.
Fixed in build1628

Relationships

child of 0009373 closedLudek iOS Bidi playlist sync fails 

Activities

Ludek

2013-03-07 12:00

developer   ~0035274

Seems to be related to 0009373:0031465

Ludek

2013-03-07 13:27

developer   ~0035276

Fixed in build 1627.

lowlander

2013-03-11 16:34

developer   ~0035337

This issue is still present on 1627:
1) Auto-Sync Playlist to iOS
2) After sync completes add files to Playlist
3) Disconnect iOS device
4) Auto-Sync Playlist

Files added in step 2 are not on Playlist in MM or iOS device.

Ludek

2013-03-12 10:22

developer   ~0035343

I can no longer reproduce the issue after the fix in 1627 unless I e.g. re-order the playlist in the device, but if I simply disconnect and re-connect the device in step 3) then everything works as expected.

Tested iTouch 4, iOS6

Which iOS version you tested? Are you sure that you tested with 1627 and that you haven't edited the playlist directly in the device? Could you re-verify?

Ludek

2013-03-12 12:07

developer   ~0035345

Last edited: 2013-03-12 12:10

View 4 revisions

Although I couldn't reproduce with 1627 and could not find a reason for it I changed the logic slightly to prevent this.

Now, if the playlist in MM was modified from the last sync then its content is always preferred (despite the playlist was modified in iPhone meanwhile).
i.e. changing playlist content in MM takes preference over the changes in iPhone

This should definitelly resolve this issue.

Added in 1628.

lowlander

2013-03-12 15:11

developer   ~0035346

iOS 6.0 on iPod Touch 4gen. Note that nothing is done on the iPod Touch at any point.

peke

2013-03-15 03:39

developer   ~0035386

Verified 1628