View Issue Details

IDProjectCategoryView StatusLast Update
0010524MediaMonkey 4Synchronizationpublic2013-03-11 22:18
Reporterlowlander Assigned To 
PriorityhighSeveritycrashReproducibilityrandom
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1Fixed in Version4.1 
Summary0010524: 'Galaxy Note' is recognized as 'Galaxy S3'
Description'Galaxy Note' is recognized as 'Galaxy S3' on first connect via USB
Steps To ReproduceI have had the Galaxy Note connected via USB (created 2 device profiles), then attempted to sync via wifi on MMA which created 2 more device profiles and failed. So I then tried to modify the device profile for a wifi created profile and on second time closing it MediaMonkey was left frozen.
TagsNo tags attached.
Fixed in build1625

Activities

Ludek

2013-02-14 15:27

developer   ~0034920

Last edited: 2013-02-14 15:27

View 2 revisions

From the log I see that it frozen on the line
TSDBUIParent: Unregistering children events
isn't it?

Is it always reproducable or it was a random error that you can no longer repro?
Did the freeze generate also ELF log?

Also strange thing is that it generated new profiles over WiFi even if there were created profiles over USB, could you attach MMDC of all 4 profiles?

lowlander

2013-02-14 18:10

developer   ~0034931

This was a one time occurrence. Elf has been attached (hope it covers this event though).

As for the Device Profiles, the following happens (no profiles for device exist):
1) Connect first via USB, new device profiles (as Galaxy S3, not Note) are created
2) Connect via wifi, new device profiles (as Galaxy Note) are created *
3) Remove MediaMonkey folders from device
4) Connect via wifi, new device profiles (as Galaxy Note) are created (now having 1 set of USB profiles and 2 sets of wifi profiles (6 in total))
5) Remove excess wifi and the USB profiles
6) Connect via USB, device uses existing wifi profiles

* Prior to step 2 removal of MediaMonkey folders on device may have taken place. This seems to be the required trigger for multiple device profiles.

Ludek

2013-02-14 19:04

developer   ~0034935

Last edited: 2013-02-14 19:06

View 3 revisions

Note that you cannot delete MediaMonkey folders on device, because it is where MMW and MMA store the pairing keys (within the StorageInfo.xml file). So if you delete them then MMA generates another key and new profile needs to be created on MMW side.

So I suppose that without removing MediaMonkey folder on the device the existing USB profiles are used for WiFi sync as expected, isn't it?

lowlander

2013-02-14 21:15

developer   ~0034941

Yes, it seems only removing the folders causes new Device Profiles. I've not tested though how this works when user sets up USB sync and after that installs MMA.
Also it would seem it's not desirable to identify the device this way (ie. MMA should have no affect on this). Can't it just use the device's unique ID?

Ludek

2013-02-14 23:20

developer   ~0034944

Last edited: 2013-02-14 23:21

View 3 revisions

The only common device identifier for MMW and MMA is Serial Number, but there are some problems with this:
- MMA can obtain it only on some android systems
- it cannot be used as storage identifier (when device have more than one storage, like your)

Therefore it is recommended to connect device via USB at first so that MMW 4.1 can write the storage identifiers to the StorageInfo.xml for MMA.

lowlander

2013-02-14 23:37

developer   ~0034946

Okay, then the problem that remains is that the device is recognized as a Galaxy S3 and not Galaxy Note (which wifi does recognize correctly).

Ludek

2013-02-15 12:27

developer   ~0034955

Last edited: 2013-02-15 12:35

View 5 revisions

Fixed in 1625.

The remaining issue ('Note' recognized as 'S3') is fixed in build 1625.
They should now be recognized correctly as 'SAMSUNG Android - Phone' and 'SAMSUNG Android - Card' (as you see them in Windows Explorer)

I have not been able repro the original issue (one time occurrence freeze) and I even have not been able to get enough info from the debug logs. Re-open another issue if you will be able to repro it again.

lowlander

2013-03-11 22:18

developer   ~0035341

Verified on 1627