View Issue Details

IDProjectCategoryView StatusLast Update
0010466MediaMonkey for AndroidSynchronizationpublic2013-03-11 00:30
Reporterlowlander 
PrioritynoneSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.1 
Target VersionFixed in Version 
Summary0010466: Wifi sync syncs unselected parent playlists of selected child playlist
DescriptionWhen syncing over wifi any parent (all levels) playlist of a selected child playlist is synced to the device even if the parent playlist hasn't been selected to be synced. This is the same if sync setup is done in MMA or MMW. USB sync is unaffected.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=21&t=69937
TagsNo tags attached.
Fixed in build103

Relationships

related to 0010500 closedpeke Playlists: We should allow that Playlist can Contain Playlist as object 

Activities

Ludek

2013-02-06 20:14

developer   ~0034821

Last edited: 2013-02-06 20:16

View 3 revisions

I think that it is OK that the unselected parent playlist is created as empty to keep the hierarchy, but there is a regression in this area.

The parent playlist is no longer parent in MMA, but is shown below the child playlist (on the same level with the child playlist) !

lowlander

2013-02-06 20:36

developer   ~0034822

Last edited: 2013-02-06 20:37

View 2 revisions

I'm not a fan of that. Due to the variety of devices (portable and UPnP) and users the only usable way of using Playlists is using a hierarchy in MMW. However this serves no purpose on portable device where all required playlists would be several levels deep without any of the parent levels having tracks nor having more than one parent on the device.
However I can see that this may be useful for some (especially the ability to sync parent/child relationship has been requested for MMA and iOS).
It seems that hierarchy (ie. Parents) should only be created if they have been selected in the sync-list. If parent Playlist(s) of a child have not been enabled the child should be synced to the root.

PS. MMW has never synced a hierarchy for Playlists to MMA or iOS for me.

marek

2013-02-20 18:40

developer   ~0035000

Fixed in build 103

peke

2013-03-11 00:30

developer   ~0035321

Re verified 108 4'th of March on all three devices and on all files that they support.