View Issue Details

IDProjectCategoryView StatusLast Update
0010230MediaMonkey (current)Framework: Taggingpublic2013-12-10 23:03
Reporterlowlander 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1Fixed in Version4.1 
Summary0010230: Drag & Drop Artwork prompts 2 file tag operations (regression)
DescriptionWhen you drag & drop Artwork onto the Art & Details window you get 2 prompts to tag the files with Artwork.

EDIT:
Seems to occur only when dragging from Firefox, dragging from Chrome doesn't add the artwork twice.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=70239
QKH-793138
TagsNo tags attached.
Fixed in build1678

Relationships

related to 0009685 closedLudek Inconsistent D&D Artwork on Art & Details vs. Artwork tab 
related to 0004814 closedpetr Drag&Drop from Firefox doesn't work 
related to 0011001 closedLudek Add Image fails in Art & Details window (regression) 

Activities

michal

2012-12-22 08:17

developer   ~0034137

Last edited: 2012-12-22 08:32

View 2 revisions

I cannot reproduce this. Is it still reproducible in 1615? On clean install? How exactly?

lowlander

2013-02-17 18:09

developer   ~0034984

Yes, this still happens on 1624. Just drag & drop (from Firefox) an image on the Art & Details window.

Ludek

2013-02-18 10:17

developer   ~0034988

Last edited: 2013-02-18 10:23

View 3 revisions

Note that it is Firefox issue, Firefox sends the file twice as:

http://media.novinky.cz/945/359451-top_foto1-esp4x.jpg?1361179805
C:\Users\Ludek-NB\AppData\Local\Temp\qyqzudoo.bmp

As you can see, the first is direct link and the second is locally cached image.
I tried to eliminate this duplicates by comparing actual picture datas, but the data is different, the former is JPG and the later is BMP.
So there isn't an easy way for MM how to find that these images are same (without pre-converting the images to the same format, but this would bring performance impact).

The same image dragged from Chrome works fine, because Chrome sends only the original link to the image.

peke

2013-06-22 02:58

developer   ~0036630

Re-assigning to me to evaluate and find better solution.

peke

2013-09-15 22:29

developer   ~0037539

I'm unable to reproduce in 1657 and FF 23.0.1

rusty

2013-12-09 14:31

administrator   ~0038605

This occurs for me every time with MM 4.1 (tested by dragging AA from firefox to the _Properties_ window). Video posted at:
http://screencast.com/t/gYHzHeRvPVA

Debug log posted to ftp.

Note: this is a regression--it doesn't occur with 4.0.7.

Ludek

2013-12-10 15:27

developer   ~0038661

Last edited: 2013-12-10 16:06

View 7 revisions

Yes, because 4.0.7 does not accept image URL links at all. That said it fails to add image dragged from Chrome, because Chrome sends only URL links (while Firefox sends both URL and local copy).

I guess I could workaround the issue and ignore the URL link in case there are two links (the first is URL link and the second is link to local file, and this way suppose that it is from FireFox), but this will be a dirty hack.

The other issue I see is, that currently MMW doesn't check mime type, it should accept only links with MIME = 'image/*'.


Fixed in build 1678 (implemented both - the dirty hack + MIME checking)

peke

2013-12-10 23:03

developer   ~0038680

Verified 1679