View Issue Details

IDProjectCategoryView StatusLast Update
0010168MediaMonkey for AndroidPlaybackpublic2016-06-02 15:58
Reporterrusty Assigned To 
PriorityurgentSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.1 
Target Version1.0.1 
Summary0010168: Playcounts aren't calculated consistently between MMA and MMW
DescriptionThere have been a few complaints about the fact that MMA considers a track played at ~10seconds, whereas MMW considers a track 'skipped' if the user advances at the 10sec mark.

MMW's current logic is:
Advance play counter: if > 1m played or anything played on track < 3m
Advance skip counter: if playback > 2s and < 3/10 of the track

MMA should take the same approach as MMW for Play counts, and ideally, should track skips as well.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=21&t=68840
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=68944
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=69025
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=69282
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=69182
TagsNo tags attached.
Fixed in build183

Relationships

related to 0007997 assignedLudek MediaMonkey (current) Skipcounts not implemented for synchronization 
related to 0010160 new MediaMonkey for Android Real PlayHistory synch 
related to 0010709 assignedLudek MediaMonkey (current) Add Skipcount sync MMW -> MMA 
related to 0011599 closedmartin MediaMonkey for Android MMA Playcounts aren't updating for some tracks (regression) 
related to 0013326 feedbackrusty MediaMonkey 5 Skip count not updated as expected 

Activities

rusty

2013-02-21 23:00

administrator   ~0035043

Raising the priority to 'Urgent' as this is one of the most common complaints about MMA.

martin

2013-03-21 19:29

developer   ~0035450

play counter - fixed in build 116

martin

2013-04-04 11:03

developer   ~0035529

added skip counter support to build 119,
remains to implement "skipcounter" usb sync support on server side
and wifi sync support on both side

marek

2013-04-04 13:45

developer   ~0035530

Skipcounter is sent over wifi properly as modification

Ludek

2013-04-04 16:09

developer   ~0035531

Last edited: 2013-04-05 08:29

View 2 revisions

Added SkipCount MMA -> MMW sync in MMW build 1630 (MMW -> MMA is tracked as 0010709)

rusty

2013-11-08 19:45

administrator   ~0038252

Tested 182.

MMW seems to advance playcounts and last played dates for music once the track has been listened to in its entirety.

MMA, however, seems to advance the playcount and last play date if only a few seconds of the track have been played!

The logic/implementations across both platforms should be the same.

For movies and other bookmarked formats, see: 0011183

jiri

2013-11-11 09:27

administrator   ~0038258

This should be modified in MMA.

Ludek

2013-11-11 10:46

developer   ~0038259

Last edited: 2013-11-11 10:47

View 2 revisions

Starting from MMW 4.0 the play counter is incresed on file end (because of bookmarkable tracks etc.)

It was slightly modified in MM 4.1: The current MMW politics is described here 0011183:0037574

martin

2013-11-12 23:45

developer   ~0038274

Fixed in build 183.