View Issue Details

IDProjectCategoryView StatusLast Update
0010135MediaMonkey for AndroidPlaybackpublic2018-07-26 19:56
Reporterjiri 
PriorityimmediateSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version1.0.4 
Target Version1.0.4Fixed in Version1.0.4 
Summary0010135: Improved support for BT connected audio devices (display metadata)
DescriptionAs reported in http://forum.mediamonkey.com/viewtopic.php?f=21&t=68893 (items 1-3), we don't properly support Audio playback over BT:
1. After playing a track, the head unit stops playing with PAUSE on the display. The phone however is still playing the next track. If I reselect the bluetooth source on the head unit again, it picks up the playing track and continues. Pressing track next/back on the head unit seems to work as expected, the next track plays over a2dp. It seems the issue is related to playlist progression, after playing one track something happens which makes the head unit think the stream has paused.

2. Randomly, while playing a track over a2dp, the track will stop. The head unit displays pause and I have to reselect the BT source again on the head unit, then press play in the android app.

3. AVRCP 1.3 Bluetooth functionality appears to be missing. While android does not support this by default, Cyanogen does and so do other phone vendors. The player is not sending track information to the bluetooth device, therefore the device (head unit) has UNKNOWN for all the metadata. The author of playerpro added this functionality to his app around 1 yr ago. Other players on google play store support this too. Could you please implement it in the Android player?

Specs:
http://affon.narod.ru/BT/bluetooth_app_c10.pdf
http://www.tscm.com/BluetoothSpec.pdf
http://www.bluetooth.org/Technical/AssignedNumbers/hci.htm
http://www.brianpday.com/docs/SPEC-00032%20Host%20Controller%20Interface%20API_1.pdf
http://www.palowireless.com/infotooth/tutorial/hci.asp
http://code.google.com/p/smalltooth/wiki/HostControllerInterface
http://en.wikipedia.org/wiki/Bluetooth
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=21&t=68893
TagsNo tags attached.
Fixed in build180

Relationships

related to 0011417 resolvedmartin Bluetooth STOP command terminates MMA 
related to 0011418 resolvedmartin Bluetooth device 'repeat' function fails 
related to 0011840 closedmartin Warning to prevent accidentally disabling bluetooth playback functions 
related to 0014988 resolvedmartin MMA should display directory contents / playlist contents over bluetooth 
parent of 0011847 closedmartin BT: Metadata not shown in sync with player 
related to 0010588 closedrusty Playback on iogear bluetooth headphones doesn't work 

Activities

peke

2012-12-04 16:44

developer   ~0033633

Last edited: 2012-12-04 17:01

View 2 revisions

My LG Optimus L5 have v3.0 with A2DP and Car Audio is LG LAC7900RN Bluetooth Specification 2.0 + EDR

peke

2012-12-04 23:57

developer   ~0033646

Last edited: 2012-12-05 01:32

View 2 revisions

Both Google Nexus 7 and My headunit are AVRCP 1.0

JB is still on older version but latest http://www.bluez.org/profiles/ support 1.3 which other manufacturers use, for now MMA is tested and have working AVRCP 1.0.

martin

2012-12-05 12:16

developer   ~0033657

Fixed in build 73 for ICS+

rusty

2012-12-06 14:24

administrator   ~0033696

Note: fix is to the 2 bugs + addition of avrcp 1.3 support. Requires testing.

peke

2012-12-07 22:39

developer   ~0033743

No regressions on both of My devices and AVRCP 1.0 using 74

peke

2012-12-08 00:22

developer   ~0033765

Based on user Feedback it is not working.

rusty

2013-01-22 15:26

administrator   ~0034579

I've tested Google Music and MM build 93 with a Satechi Soundview. My findings are that Google Music works as expected but that for MM:
1) Play controls work as expected (Play/Prev/Next/Stop)
2) Metadata fails to display

martin

2013-01-23 19:01

developer   ~0034647

Rusty Google Music and MMA was tested from same device?

Android music widget in JB 4.2 is filled in the same way as remote device. There was bug with album art and artist, but song title and album name should be sent correctly.
I have no device to test so please verify if it works already.

I attached screenshot of widget which I was talking about.

martin

2013-01-23 19:01

developer  

unknownAndroidWidget.png (136,609 bytes)
unknownAndroidWidget.png (136,609 bytes)

martin

2013-01-23 19:02

developer   ~0034648

Fixed in build 95.

rusty

2013-02-21 23:16

administrator   ~0035044

Users have reported at http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=68893 that this is still not working correctly. Specifically:
- metadata isn't displaying
- zombiefly indicated that in some cases tracks stop randomly while playing (though this might also be a manifestation of 0010550)

I can confirm based on testing with a Soundfly device that the Samsung player or Google Music running on my S3 correctly display metadata on the device, but MMA doesn't. Play/Next/Prev work correctly.

martin

2013-03-25 16:25

developer   ~0035481

hopefully fixed in build 117.
Maybe null bitmap caused that no metadata was set. Check it please and if metadata is not still displayed, upload your log file.

jiri

2013-04-04 08:35

administrator   ~0035526

Per reports in http://forum.mediamonkey.com/viewtopic.php?f=21&t=68893&start=15#p363601 it still doesn't work well.

rusty

2013-04-08 17:00

administrator   ~0035577

Sending log that covers:
Turned on Bluetooth
Ran MM
Played 'Astair' pressed pause
Played 'Broken' clicked 'next'
Played 'Cocoon'
--> Metadata failed to display for all three

Ran Samsung Music Player
Played 'Spider man', clicked next
Played 'Don't fear the reaper'
--> Metadata displayed for both tracks

martin

2013-05-28 16:19

developer   ~0036210

Hopefully fixed in build 134, due to hack using 'com.android.music.metachanged' intent.

rusty

2013-05-29 21:11

administrator   ~0036230

Tested 134 and observed that:
- Upon initiating playback, Title metadata displayed for the first track that is played, but not for any subsequent tracks.
- 'Artist' metadata failed to display completely

rusty

2013-05-30 22:08

administrator   ~0036249

Last edited: 2013-06-10 21:02

View 5 revisions

Build 136:
- Works on the Pebble watch
- Displays metadata on a Mazda3 radio. BUT when the second track plays, the radio thinks that the music was paused on the phone and displays "PAUSED", while the music keep playing. Pausing the music in MMA then hitting the play button on my radio restart the music and display the information again, until the song ends.
- has a regression on the Soundfly View: no metadata is displayed at all

Build 139:
- Toyota bluetooth radio: same behavior as mazda3 radio

martin

2013-06-05 13:13

developer   ~0036333

Please verify in build 140, maybe pausing issue is fixed.

peke

2013-10-28 11:08

developer   ~0038080

Last edited: 2013-10-28 11:25

View 2 revisions

Verified 177 with Lancia Delta 2010 Headunit but 0011417 0011418 remains to be solved

rusty

2013-10-30 18:05

administrator   ~0038118

Last edited: 2013-11-08 17:11

View 2 revisions

In recent testing, I've found that the metadata sometimes fails to display (I've noticed this when playback is initiated via MMA, rather than via bluetooth, but I'm not sure if this is consistent).

Also, a user reported that metadata is missing from the Sony SBH50 / SBH52 ( http://www.sonymobile.com/global-en/products/accessories/stereo-bluetooth-headset-sbh50/ ) : http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=74230

martin

2013-11-06 12:09

developer   ~0038198

Last edited: 2013-11-06 16:02

View 2 revisions

for older android versions, I guess for API < 16, has to be installed
https://play.google.com/store/apps/details?id=com.sonymobile.smartconnect.collins

but there is issue for track with Unknown artist, its metadata are ignored.
This issue is fixed by space added as prefix.

Tested with devices: Nexus 7, SE MK16i
Fixed in build 180.

rusty

2013-11-08 18:34

administrator   ~0038249

Last edited: 2013-11-10 03:29

View 2 revisions

verified 182 gs3/androd 4.1.1 with Satechi bluetooth device

and martin confirmed that the SBH52 now works with devices it was tested with.

rusty

2013-11-10 03:38

administrator   ~0038255

User is still experiencing a problem with the SBH52 and MM, even though it works with other apps :-(

See: http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=74230

rusty

2013-11-19 05:52

administrator   ~0038333

Debug log is uploaded. See http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=74230#p377856

jiri

2013-11-19 12:25

administrator   ~0038335

Decreasing priority as we aren't able to find out any reason for this problem. To be resolved after 1.0 release and possibly when we are able to reproduce internally.

rusty

2014-01-27 19:01

administrator   ~0039384

Another report of MMA not displaying bluetooth metadata:
http://www.mediamonkey.com/forum/viewtopic.php?f=21&t=75230

jiri

2014-02-07 10:53

administrator   ~0039531

Resolving, since the only known problem will be resolved by 0011840. Needs to be reopened in case we get any new report...