View Issue Details

IDProjectCategoryView StatusLast Update
0010071MediaMonkey (current)Install/Configpublic2013-02-25 01:52
Reporterrusty Assigned To 
PriorityurgentSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1Fixed in Version4.1 
Summary0010071: File Associations don't function as expected in Windows 8
DescriptionWhen the user sets file associations and/or the option to re-associate file associations (on a windows 8 system), MM does not become the default app.

This is because File associations don't work in Windows 8 in the same manner in which they work in XP-Win7. Details at:
 http://msdn.microsoft.com/en-us/library/windows/desktop/hh848047%28v=vs.85%29.aspx
 
To summarize: prior to Win8, setting a file association meant setting a default file association. In Win8, setting a file association means notifying the system that the application is able to manage the file type, but the default association can only be set by the system.

A couple of context help string changes will deal with much of this:
i) This allows you to select which file types will be associated with MediaMonkey, so that if the file is double-clicked, MediaMonkey will automatically run and play the file.
-->
This allows you to select which file types will be associated with MediaMonkey, so that if the file is double-clicked, it can be played in MediaMonkey (Windows 8) or will automatically play in MediaMonkey (XP, Windows 7).

ii) Some applications are set to 'steal' file associations, so that even if you've configured MediaMonkey to play MP3 files, the other application overides this setting. If you want to be certain that MediaMonkey will run, enable 'Re-associate file types on startup' to reset file associations each time you run MediaMonkey.
-->
In operating systems prior to Windows 8, some applications are set to 'steal' file associations, so that even if you've configured MediaMonkey to play MP3 files, the other application overides this setting. If you want to be certain that MediaMonkey will run, enable 'Re-associate file types on startup' to reset file associations each time you run MediaMonkey.


As far as functional changes:
i) If MediaMonkey detects that Windows 8 is the OS, don't display the '[ ] Re-associate File Types on Startup' option

ii) In the future, we may decide to add a shortcut to the 'Set Default Programs' system functionality, but I don't believe that this is a requirement.
Additional InformationPetr, re-assign to Rusty, once functional change is implemented.

http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=68998
TagsNo tags attached.
Fixed in build1623

Relationships

related to 0009453 closedpetr MediaMonkey (current) Windows 8 compatibility 
parent of 0011615 resolvedLudek MediaMonkey (current) Associate File Types fails without warning on Portable Install 
has duplicate 0010108 closedrusty MediaMonkey (current) MediaMonkey doesn't show as Default Program for supported file types on Windows 8 

Activities

petr

2013-01-02 19:49

developer   ~0034238

Re-associate checkbox hidden in Windows 8.

rusty

2013-01-21 16:35

administrator   ~0034557

Last edited: 2013-01-22 18:16

View 2 revisions

The string changes described above still need to be made for MMW 4.1.

Also, if it's trivial to add a button (on Win 8 Systems only) for 'Set default programs...' (just below the list of file associations), it would be useful--though not critical.

Edit: we could probably even add a button (on Win 8 Systems only) 'Set default programs...' _instead_ of the list of file associations, so long as MMW correctly reports all of the file types that it supports.

petr

2013-01-22 18:31

developer   ~0034602

I think we can leave extensions list visible, as it work correctly (this register MMW as a handler of specified extensions).
Only problem is that user need to make MMW default app.

Ludek

2013-01-22 19:48

developer   ~0034607

Last edited: 2013-01-22 19:54

View 5 revisions

Discussed with Petr and there is a misunderstanding.

Currently it works this way:
MM registers all extensions that it supports (all listed) in the system "Default Programs/MediaMonkey 4/Choose Defaults for this program"

What Petr suggests is that MM should register only selected extensions in the system

This would imply to change behaviour of the extension checkbox which had always meaning of "associating" and Petr suggests to change the meaning to "registering".

IMHO I think that it is quite confusing therefore I tend to Rysty to hide the extension list in MM Options and just add new button as shortcut to
"Set Default Programs/MediaMonkey 4/Choose Defaults for this program" (supposing it is possible)

rusty

2013-01-22 20:37

administrator   ~0034609

Yes--I agree. I don't think that there's much benefit to allowing the user to 'Register' which extensions are supported in MM, and then choosing which of those are 'Associated' via Windows System dialogs.

To me it makes more sense to just 'Register' all file types supported by MM (i.e. no UI for this), and then letting the user choose file associations via Windows System dialogs--which MM has a shortcut to.

rusty

2013-01-22 20:40

administrator   ~0034610

The only questions remaining are:
1) whether any special logic is needed to handle upgrades from previous versions of MM
2) what to do in portable mode

Ludek

2013-01-22 20:59

developer   ~0034611

Last edited: 2013-01-22 23:25

View 2 revisions

We can jump directly to "Set Default Programs/MediaMonkey 4/Choose Defaults for this program" by using
http://msdn.microsoft.com/en-us/library/windows/desktop/bb776330(v=vs.85).aspx

Ludek

2013-01-22 23:32

developer   ~0034614

Implemented in build 1623.

Ludek

2013-01-23 00:19

developer   ~0034616

Last edited: 2013-01-23 00:22

View 2 revisions

Re-opened because of the question 2) what to do in portable mode

From what I see, currently (in Portable mode) nothing is associated until user associate it manually via Options|OS integration


But in this case it is problematic, because MM needs to be registered as default program so that user could change the associations.

So I guess that possible solutions are:

a) Let MM checks (on every start) whether it is properly registered as default program and if it is not then register it as default program on each computer.

b) Register MM as default program once user clicks the [Associate file types with MediaMonkey...] button.


I think that solution b) is more consistent with the current approach?

Ludek

2013-01-23 10:38

developer   ~0034635

Implemented in build 1623 using solution b) for Portable mode.

stephen_platt

2013-02-25 01:52

developer   ~0035096

verified 1625