View Issue Details

IDProjectCategoryView StatusLast Update
0015739MediaMonkey 5Playbackpublic2019-07-01 19:00
Reporterpeke 
PriorityurgentSeveritycrashReproducibilitysometimes
Status resolvedResolutionreopened 
Product Version 
Target Version5.0Fixed in Version5.0 
Summary0015739: Online Track Playback: Some Tracks can't be played
DescriptionSome tracks when tried to play using online API player fail even original URL play in browser.
Steps To Reproduce1. Browse Online Search for Album artist
2. Try to play track
3. Try to change Search Results of online playback (Right click -> Search Results -> [SOME OTHER TRACK RESULTS]
4. Track Fail to play
5. Repeat Step 4 and select Original Search result -> Track play
TagsNo tags attached.
Fixed in build2184

Activities

peke

2019-06-13 01:35

developer  

bug15739_1.jpg (330,851 bytes)
bug15739_1_2.jpg (363,417 bytes)
bug15739_2.jpg (378,215 bytes)

michal

2019-06-13 07:27

developer   ~0053807

Last edited: 2019-06-13 07:28

View 2 revisions

It is expected behavior. Some Youtube videos contain only H264 version, which cannot be played in MM5 (our Chromium does not contain H264 codec, because of the license, it can play only WebM). Youtube API cannot filter results based on this, we have to try to play the track to find out, whether it is really playable. We have automatic fallback, it tries the next track from the searched list after the fail. This fallback is suppressed, when the YT track is selected manually from Search results.

michal

2019-06-13 09:00

developer   ~0053809

Reopening, found out, that it is causing strange crash in Chromium ceflib.dll:
1) open mentioned online album "Freight Train", artist Alan Jacskon
2) play third track "After 17" -> it fails to play first YT track and starts to play the second.
3) right-click on art window - Search result - select first item ("Alan Jackson - After 17 wth Lyrics ") -> it does not play
4) close MM5 -> crashes to white screen, sometimes with Eureka log, sometimes without.

We should analyze, whether we could do something with this bug, it could be bug in Chromium too.

peke

2019-06-13 10:55

developer   ~0053810

Last edited: 2019-06-13 10:56

View 2 revisions

I have not observed White Screen crash initially but if Non playing track was playing one and you close MM5 then I can replicate WhiteScreen Crash.

michal

2019-06-13 10:58

developer   ~0053811

Last edited: 2019-06-13 10:58

View 2 revisions

Yes, it occurs when non playing track is trying to play twice (for the first time you may not notice the attempt because of quick fallback to another track).

michal

2019-06-14 16:30

developer   ~0053825

The problem is in context menu opened above youtube window (EmbeddedWindow of type "ytplayer"). When user opens this context menu, on any YT video, it causes, that app crashes during shutdown, most often to white screen. Sometimes it crashes even sooner. Petr please look at it, it will be related to this special kind of window, thanks.

petr

2019-06-17 21:19

developer   ~0053859

Fixed

peke

2019-06-22 02:35

developer  

bug15739.jpg (303,284 bytes)

peke

2019-06-22 02:37

developer   ~0053936

It still fail for the affected track sample when you change search result.

Sent you track offline.

michal

2019-06-22 06:59

developer   ~0053937

As described above, this is expected. If you force MM to play some exact search result, and this search result has only H264 version on Youtube, playback fails this way. Our Chromium cannot have H264 decoders because of the license. Youtube converted most of videos to WebM, but there are still some, which are H264 only, and such cannot be played in MM5. We sadly cannot detect this situation in advance. Or did you reproduce the crash again?

peke

2019-06-23 21:30

developer   ~0053949

White Screen Crash Happen each time I try to play same track twice. Second time MM5 simply stops playback where first time it skips to next track in search results.

michal

2019-06-24 06:54

developer   ~0053950

Reproduced, seems to be still some problem when context menu was opened above YT window.

petr

2019-06-25 08:07

developer   ~0053967

Fixed

peke

2019-07-01 19:00

developer   ~0054041

Verified 2185

Please Close after another confirmation