View Issue Details

IDProjectCategoryView StatusLast Update
0015156MediaMonkey 5Now Playingpublic2018-11-15 01:43
Reporterrusty 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version5.0 
Target Version5.0Fixed in Version5.0 
Summary0015156: Right column behaves strangely in Now Playing mode
DescriptionCurrently, the NP functionality causes strange behavior for the right-column control:

0 Click the three horizontal lines in the upper-right to collapse and expand the NP list/A&D window
--> The right column contracts/expands as expected
1 Click NP tree node or NP window header
--> NP Track metadata appears (i.e. NP view opens)
2 Click the three horizontal lines to collapse the NP list/A&D window
--> The right column expands a bit more, then contracts to it's original size. And the content becomes all greyed out and the Art & Details view is hidden! This is a confusing--it's unclear to the user what has happened or why (since the control should just collapse the column. To the user it almost seems as if it's a bug since selection/editing stopped working for some unknown reason.
3 Click 'Now Playing' header in order to close the right-hand column / view
--> Playback stops and the view doesn't change!

This can be fixed superficially by:
a) changing the animation so that it works as it normally does. i.e. at step 2 above, the right column should just collapse as it normally does, revealing the NP view that was 'hidden' underneath, so that the user can see that clicking the 'three lines' just collapsed the right-hand column.
b) changing the layout of the NP view so that the list of tracks that appears within looks different than the right-hand column (so that it looks like a different view rather than the current view getting greyed out).
c) making it so that if the user clicks the 'Now Playing' header, that focus switches to the last viewed node

Considering the limited added value of the Now Playing 'Full list' list (since it's almost identical to the right-column), a simpler solution could be to just eliminate the list. i.e. change it to 'Full' view (rather than 'Full list' view.

Thoughts?
TagsNo tags attached.
Fixed in build2131

Activities

jiri

2018-10-17 13:47

administrator   ~0051361

The problem was mostly caused by the need to show the 'NP list' in the 'NP view', but avoid duplicate NP lists shown next to each other (i.e. the second one is the part of the right-side panel).

I made few modifications:
 - Moved the list in the NP view to the left side, so that it's no longer next to right-side panel.
 - The visibility of these two is no longer automatically exclusive, there isn't any relation now.
 - Split the view to two, named 'Default' and 'Default + List', where only the second one contains the NP list, the first one only shows the right-side info about the current track.

michal

2018-10-25 08:03

developer   ~0051446

Info panel on the right side is very unnatural, I think it is not good idea. I would rather choose something like b), maybe change track list to only "Coming up" box and display it e.g. in the bottom part showing info about next track (if it is known, probably hide this in case of shuffled playback). If user would like to see whole tracklist, he/she can display standard NP list panel.

jiri

2018-10-25 08:39

administrator   ~0051447

Sounds good to me.

michal

2018-10-26 11:54

developer   ~0051483

Fixed in build 2131. Default layout now displays only "Coming up" line. Default+List layout displays original LV, so user can choose, whether to display LV from NP view or from the right NP panel or both. Consider removing whole Default+List layout.

peke

2018-11-15 01:43

developer   ~0051543

Verified 2132