View Issue Details

IDProjectCategoryView StatusLast Update
0009563MediaMonkey (current)Framework: Skinningpublic2013-09-12 03:27
Reporterpeke Assigned To 
PriorityurgentSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version4.0.6 
Target Version4.1Fixed in Version4.1 
Summary0009563: Some fonts / dropdowns always appear black
DescriptionAs pointed by DreadM there are need for skinning improvements:
1. Font color for native/default MM functions
  a) Font of default Libraries that are installed by default with MediaMonkey are always printed in Black Color. As this is in MM code itself We should add this to Settings.ini

2. Toolbar Objects with dropdown Menu (Send To, Tools) should share same skinning elements as Play Now. NOTE: This is maybe for separate BUG/FEATURE It could be also very useful to have option that This kind of object can retain last selected Action Like REDO in some applications and will make skinners job much easier for not making two separate skin objects.
TagsNo tags attached.
Fixed in build1657

Relationships

has duplicate 0009565 resolvedpetr Combo buttons sometimes aren't skinned correctly 
related to 0008732 closedpetr Font color in the Art and Details window cannot be changed from black 
related to 0008928 closedLudek CheckBox font color in Options > Edit media Tree cannot be changed by skin 

Activities

peke

2012-08-11 00:11

developer  

defaultlibrariesfont.png (16,013 bytes)   
defaultlibrariesfont.png (16,013 bytes)   

peke

2012-08-11 00:14

developer  

ToolbarArrows.png (9,071 bytes)   
ToolbarArrows.png (9,071 bytes)   

rusty

2013-03-11 20:33

administrator   ~0035340

Set to 'urgent' since we're hoping to include a dark skin in MM 4.1.

rusty

2013-06-07 03:22

administrator   ~0036366

Last edited: 2013-09-03 21:34

View 2 revisions

Some other text that always appears black:

3.
Device Profile > Auto-Sync --> Library > Destination -- always appears black
Device Profile > Options > Auto-conversion > Target Volume Level __ dB -- always appears black

Ludek

2013-09-03 21:35

developer   ~0037411

Last edited: 2013-09-03 21:58

View 4 revisions

Item 1) is duplicate of 0008928 (Fixed in build 1657)

Items 2 & 3 fixed in build 1657.

Item 4)
Media Sharing > Auto-conversion > Target Volume Level __ dB -- always appears black
=> Fixed in build 1657.

Ludek

2013-09-05 20:04

developer   ~0037431

Last edited: 2013-09-05 20:05

View 2 revisions

Item 5)
Options -> Party Mode -> Player Controls are in black

Item 6) Options -> Player -> Visualization plugins -> _Download more vis plugins...__ link appears in black
The same for Input, Output, DSP and Genreal plugins

=> Fixed in build 1657.

peke

2013-09-12 03:27

developer   ~0037478

Verified 1657