View Issue Details

IDProjectCategoryView StatusLast Update
0008647MediaMonkey (current)Install/Configpublic2011-12-15 03:18
Reporterrusty Assigned To 
PriorityimmediateSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0008647: MM3 --> MM4 upgrade: many config settings are lost
DescriptionOn upgrade to MM4, the majority of config settings are lost! Here's a sampling of config items that I'd tested:

Update check (lost)
Close to tray (lost)
Hotkey settings (retained)
Confirm modifications to > 50 files at once (lost)
Party Mode: disable player controls and track re-ordering (lost)
Play Now Action: Selected tracks only (lost). Note: should be transferred to all playback rules.
Retain 25 tracks in Now Playing (lost)
Podcast path: lost according to user (see link below) and triggers bug 0008643
Podcast: global config - Delete episodes older than 3 days (lost)
Library: ignore tracks < 15s (lost)
File Monitor: any configured folders (lost)
Appearance: show all tracks in A&D view (lost)
Appearence: change in field splitter to '&' (lost)
Device: Sync list (retained), Delete tracks not on device (retained), Auto-conversion rule (retained)
Podcast subscription: retained
Custom Filter: retained but disabled--it shouldn't be disabled!!
Output plugin: SQRsoft (configuration to use that plugin are lost, plugin settings are lost)

Note:
This was tested on Win7 x64, by installing MM3 to C:\Program Files (x64)\MediaMonkey and then installing MM4 to that same directory
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=61619
TagsNo tags attached.
Fixed in build1456

Relationships

related to 0008653 closedrusty Global .ini location not supported (regression) 
related to 0008773 closedpetr MM4 doesn't use MM3's custom DBNAME setting on upgrade 

Activities

Ludek

2011-11-06 22:26

developer   ~0028681

Last edited: 2011-11-06 22:27

View 3 revisions

Rusty, it looks that all values from MediaMonkey.ini were not transferred, this happens only if you install MM4 in portable mode. Did you install MM4 in portable mode?

Ludek

2011-11-06 22:49

developer   ~0028682

Last edited: 2011-11-06 22:51

View 2 revisions

Another (and most probably more logical reason) is that you have already installed MM4 on that machine and it just taken the MediaMonkey.ini from the previous MM4 install?

So try to re-test, but delete AppData\Roaming\MediaMonkey\MediaMonkey.ini before installing.

Ludek

2011-11-06 23:23

developer   ~0028683

Last edited: 2011-11-07 00:32

View 5 revisions

Just tried and it is reproducable. The workaround is to delete AppData\Roaming\MediaMonkey\MediaMonkey.ini and run MM4 again. The problem is that MM4 installer creates another MM.ini, but if you delete it before the first MM4 launch then MM4.exe automatically import MM.ini from MM3 version.

I believe this is a regression, MM installer should not create the MM.ini, this is also how MM4 detects the first time run and based on this launches the first time run wizard. Currently it looks that 0007643 is never applied as installer always creates the MM.ini

Ludek

2011-11-07 17:18

developer   ~0028698

Last edited: 2011-11-07 17:48

View 7 revisions

Fixed in build 1456.

Note that further testing and SVN searching shown that MM installer always creates the MM.ini file (it need to write language and skinned/skinless settings there).

So this is fixed now and MM.ini from version 3 is copied by installer and not at MM start up.

rusty

2011-11-07 17:44

administrator   ~0028700

Test note:
Installer should be tested in the following scenarios:
XP - Clean install
XP - Clean install (portable)
XP - Upgrade from MM3
XP - Portable install on machine with MM3
Win7/Vista - Clean install
Win7/Vista - Clean install (portable)
Win7/Vista - Upgrade from MM3
Win7/Vista - Portable install on machine with MM3

peke

2011-11-09 00:35

developer   ~0028741

Last edited: 2011-11-09 00:35

View 2 revisions

Tested with Win7 and 1456:
OK - Clean install
OK - Clean install (portable)
OK - Upgrade from MM3
OK - Portable install on machine with MM3

peke

2011-12-15 03:18

developer   ~0029484

Verified 1461