View Issue Details

IDProjectCategoryView StatusLast Update
0007226MediaMonkey (current)Synchronizationpublic2011-05-23 22:52
ReporterLudek 
PriorityurgentSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version4.0 
Target Version4.0Fixed in Version4.0 
Summary0007226: Devices using WMDM can't be ejected (aka General Format plugin is unstable)
DescriptionDuring testing of 0007213 I found one problem.
If I plug-in a common USB stick (e.g. flash memory) and start MediaMonkey then its content is scanned, but even if the scanning is complete it is impossible to eject the device until MediaMonkey is closed
TagsNo tags attached.
Fixed in build1346

Relationships

related to 0007355 closedmichal MediaMonkey (current) OGM, RM Video formats don't scan / indicate file length 
has duplicate 0007291 closedmichal MediaMonkey (current) FLV: Length not Read 
related to 0007213 closedLudek MediaMonkey (current) Clicking Eject button to the right of USB MS device --> AV 
related to 0007354 closedmichal MediaMonkey (current) Some .mov files don't scan 
related to 0007317 resolvedmichal MediaMonkey (current) MPEG-PS, MPEG-TS (MPEG1/2) format plugin 
related to 0007326 closedmichal MediaMonkey (current) Implement FLV format plug-in 
related to 0006967 assignedmichal MediaMonkey 5 DVD playback 
related to 0007353 resolvedmichal MediaMonkey 5 WebM Support 
related to 0007363 closedmichal MediaMonkey (current) Scanning .mkv file, that is not in Matroska format, leads to runtime error 

Activities

Ludek

2011-01-24 22:27

developer   ~0022567

Last edited: 2011-01-24 23:41

View 6 revisions

I have debugged the issue and it is caused by tag reading from MOV files.
MOV files are locked by MM until MM is closed
The MOVs also cannot be deleted until MM is closed.

The same issue appears if MM just read tag from a MOV that is placed anywhere, the file is locked until MM is closed. Sample MOV file is attached on FTP.

michal

2011-01-26 15:28

developer   ~0022635

Fixed in build 1346. In consequence of this, file formats, which does not have format plugin, will have unknown video length and size. This should be fixed by other format plugins in the future (MOV, MPEG1/2, FLV, OGV). This solution will be also noticeably faster and safer.

stephen_platt

2011-02-07 04:05

developer   ~0022860

verified 1346

rusty

2011-02-10 17:36

administrator   ~0023005

Last edited: 2011-02-10 17:37

View 2 revisions

Additional notes for testers:

The fix to this bug was to replace the general format plugin, which relied on DirectShow to determine video file length / frame size, with custom format plugins per container type:
AAC plugin - MP4, M4V and MOV (not all kinds of MOV yet)
f_AVI - AVI, DIVX, XVID
f_MKV - MKV
f_WMV - WMV, WM, ASF

In addition, format plugins will be created for other content types based on the following order (by priority):
MPEG-PS, MPEG-TS containers for MPEG1/2 (0007317)
MOV, QT (complete support--some types are still unsupported)
FLV, F4V (0007291, 0007326)
DVD (0006967)
WebM (VP8 is video codec) (0007353)
3GP, 3GPP (may already be covered by AAC plugin)

Finally, for OGV/OGM, and RM, and other formats for which a Format plugin doesn't exist, use general DirectShow plugin (0007355)

Re-set to resolved, since I'm not sure if testing covered for possible regressions in relation to the functionality described above.

peke

2011-05-23 22:52

developer   ~0025600

Verified 1378