View Issue Details

IDProjectCategoryView StatusLast Update
0007159MediaMonkey (current)Framework: Taggingpublic2011-06-13 00:07
Reporterrusty 
PriorityimmediateSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.2.4 
Target Version4.0Fixed in Version4.0 
Summary0007159: Comment Tag differs between MM and Windows
DescriptionIn cases where multiple comment tags have somehow been added to a track tag, MM displays and edits a different comment than Windows Explorer. This confuses users, and leads them to believe that MM isn't correctly reading their tag modifications.

Suggested solution:
MM should display the contents of both tags in a single comment field. When the comment is updated, MM should combine the two comment tags into one.

Note:
The suggested solution above doesn't apply to 'special' comment fields (e.g. MusicMatch fields, which are read/written via other fields).
Additional Informationhttp://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=10411

http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=10600

http://www.mediamonkey.com/forum/viewtopic.php?f=1&t=54410
TagsNo tags attached.
Fixed in build1372

Relationships

related to 0007181 closedLudek MediaMonkey 5 Support for InitialKey (TKEY) Values in MM Library 

Activities

jiri

2011-01-11 16:26

administrator   ~0022300

I think that the best solution depends on how many different 'special' comments fields are out there. If we could identify all of them, a solution close to the suggested above would be possible. Another option would be to use the first comment found in the tag. Or possibly the first one without a description field.

Peke, please compile a list of 'special' comment fields used by other apps (MusicMatch fields are clear, but there are probably others, definitely something from iTunes). Do they all use Description field?

peke

2011-01-17 13:48

developer   ~0022372

Last edited: 2011-01-17 15:45

View 2 revisions

1. I have not found any additional Comment tags from iTunes that we do not read already.

2. As seen in Ticked PLC-857799 attachment I have sent to user only thing that is unclear should MM import first COMM tag instead of last found in ID3. From technical point of view MM import last correctly.

3. Several DJ Apps (Tractor, Mixvibes, Platinum Notes, Mixed in Key) Use TCOMM for InitialKey as explained in 0007181 and is related to Ticket YQI-375152 and should be handled there.

rusty

2011-05-06 14:25

administrator   ~0024894

Peke, I'm not quite clear about why this has been tagged as resolved. The file that the user submitted clear displays differently in MM vs WMP vs MP3Tag (MM only shows the last Comment--see attached images).

Shouldn't MM somehow be able to display all comment tags together, and concantenate them so that the user can eliminate whatever garbage is contained within?

rusty

2011-05-06 14:25

administrator  

mediamonkey.jpg (43,160 bytes)
mediamonkey.jpg (43,160 bytes)

rusty

2011-05-06 14:25

administrator  

windows_explorer.jpg (36,519 bytes)
windows_explorer.jpg (36,519 bytes)

rusty

2011-05-06 14:25

administrator  

mp3tag.jpg (38,348 bytes)
mp3tag.jpg (38,348 bytes)

peke

2011-05-09 02:40

developer   ~0024945

Last edited: 2011-05-09 02:46

View 3 revisions

Rusty,
Jiri should better explain the reason for No Change Required (Or Won't fix). I toughly explained same thing to user in Ticket PLC-857799 along with attachment.

Only exclusion I have found is already tracked in 0007181

EDIT: I re-downloaded User file and in Windows explorer COMMENTS is still empty like in my Ticket attachment

jiri

2011-05-10 10:16

administrator   ~0024993

Fixed in build 1372.
 - All ID3v2 comment fields that don't have any additional description (which is a special ID3v2 field) are concatenated and also written as a single comment field when the tag is updated.
 - Tested on the user submitted track.

peke

2011-06-13 00:07

developer   ~0026063

Verified 1387

It looks that this is best approach.