View Issue Details

IDProjectCategoryView StatusLast Update
0005373MediaMonkey (current)Otherpublic2009-04-03 22:42
Reporterrusty 
PriorityimmediateSeveritymajorReproducibilitysometimes
Status closedResolutionfixed 
Product Version3.1 
Target Version3.1Fixed in Version3.1 
Summary0005373: IE8 triggers connection problems (wininet error) on Vista / Windows 2008
DescriptionUsers of Vista and Win2008 are experiencing connection problems for Podcasting (and Auto-Tag from Amazon?), after their systems have been updated to IE8. It appears to be related to the TIE component and occurs with both MM 3.1 build and MM 3.0.7.

The error typically appears as:
Wininet error #126 : (Unknown WININET error)

Potential workarounds that have failed thus far are:
Running IE (worked in one case)
Registering the wininet.dll (solved the problem for a short time, but then it recurred)
Re-installing MM

We may have to defer if no solution is found (it isn't a new problem).
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=7&t=36487
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=4006
TagsNo tags attached.
Fixed in build1228

Relationships

related to 0005437 closedpeke Last.fm plugin Last.fm Scrobbler connection problems when IE8 Installed 
related to 0003360 closedLudek MediaMonkey (current) Use single internet access library instead of TIE + Indy 

Activities

petr

2009-03-11 23:28

developer   ~0017066

Fixed in 1227

Ludek

2009-03-12 17:54

developer   ~0017075

I found another bug in TIE that could cause this.

Fixed in 1227 too.

Ludek

2009-03-23 10:08

developer   ~0017173

Last edited: 2009-03-23 10:11

User in this ticket
http://www.mediamonkey.com/support/staff/index.php?_m=tickets&_a=viewticket&ticketid=4006&offset=10
indicated that build 1228 fixed it!

That is strange, because we made these changes in build 1227.

Ludek

2009-03-23 10:29

developer   ~0017174

Also another user indicated that it is fixed in build 1228:
http://www.mediamonkey.com/forum/viewtopic.php?f=7&t=36487&st=0&sk=t&sd=a&start=30

petr

2009-03-31 23:28

developer   ~0017249

Fixed same issue in LastFM Scrobbler plugin (build 1231).

stephen_platt

2009-04-03 22:42

developer   ~0017343

verified independently by several users in 1228 and no regressions introduced in scrobbling build 1232.