View Issue Details

IDProjectCategoryView StatusLast Update
0005072MediaMonkey (current)Framework: Scripts/Extensionspublic2009-06-11 23:40
ReporterOwyn 
PriorityimmediateSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version3.1 
Target VersionFixed in Version3.1 
Summary0005072: Pre-test for Admin (warning for add-ons installation)
DescriptionI have switched to normally NOT Running as Administrator on Vista to get Drag & Drop to work.

However, Adding or Removing an extension (mmip) requires Admin and can fail with partial changes to MM.

MM should pre-test for Admin (if possible) on Vista before executing the action, and, if not in the correct mode, present a user warning message.
Additional Informationhttp://www.mediamonkey.com/forum/viewtopic.php?f=6&t=35134
TagsNo tags attached.
Fixed in build1219

Relationships

related to 0004912 closedLudek Non-Admin users can't install scripts 
child of 0003702 closedLudek Extensions: Cleanup/Support for non-Admin installation of plugins 

Activities

rusty

2008-12-21 06:59

administrator   ~0015768

Possible warning:

'To install an add-on you must be logged in as administrator.'

Owyn

2008-12-21 07:52

updater   ~0015769

To install or remove...

Owyn

2008-12-21 07:56

updater   ~0015770

Hmmm.
"To install or remove an add-on on Windows Vista you must Run MediaMonkey as Administrator"

Owyn

2008-12-21 08:33

updater   ~0015771

You can test for correct mode by trying to create (or modify) a file in the MM %Program Files% folder.

jiri

2009-01-09 12:56

administrator   ~0016102

I added IsUserAdmin() to Utils.pas, so we can easily implement it. I'd use

"To install or remove an add-on you must Run MediaMonkey as Administrator"

and show it for Vista+ only (based on isVista variable).

Ludek

2009-01-09 14:03

developer   ~0016106

Fixed in build 1210.

stephen_platt

2009-01-13 02:46

developer   ~0016166

Last edited: 2009-01-13 02:46

We're seeing problems with uninstalling extensions (receiving "To install or remove an add-on you must Run MediaMonkey as Administrator" whether MM is opened as admin or not). I also received an exception when attempting to install an extension.

http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=35988&p=185385#p185385

Ludek

2009-01-13 12:23

developer   ~0016171

Jiri, could you look into this as you wrote the IsUserAdmin() function and I have not Vista installed.

jiri

2009-01-13 13:43

administrator   ~0016174

The fix should be based on http://msdn.microsoft.com/cs-cz/magazine/cc163486(en-us).aspx

Ludek

2009-01-13 23:58

developer   ~0016197

Reminder sent to: petr

Fixed in build 1213.

Tested on XP.
Petr, please test it on Vista, should work fine now.

petr

2009-01-14 00:39

developer   ~0016198

Verified in Vista.

Ludek

2009-01-15 23:07

developer   ~0016255

Reopened, because here:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=35988
is reported:

I start MM without admin privileges and attempt to install a script I get "Product installation error" and not the "You must run MediaMonkey as admin" message.

Petr, could you please re-test without admin privilegies whether the IsUserAdmin() function I rewritten works fine on Vista?

petr

2009-01-16 16:15

developer   ~0016264

Fixed in 1214

Ludek

2009-01-26 20:53

developer   ~0016392

Last edited: 2009-01-26 21:26

As reported here:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=35988
it is problem for Win XP too.ยด

i.e.
I've noted that on XP, extension installation info is written to
C:\Documents and Settings\All Users\Application Data\MediaMonkey\Extensions.ini
which I suppose does not work unless you're admin on the machine.

We should select one of these items:
a) change the path to C:\Documents and Settings\<User>\Application Data\MediaMonkey\Extensions.ini
b) change the path to C:\Program Files\MediaMonkey\Extensions.ini
c) give user the same warning as for Vista

Ludek

2009-01-26 21:31

developer   ~0016394

Chosen c) for now (build 1219), a) & b) tracked in 0004912.

peke

2009-06-11 23:40

developer   ~0018381

Closing Other future issues will be tracked over 0004912 and 0003702