View Issue Details

IDProjectCategoryView StatusLast Update
0014472MediaMonkey (current)Codecpublic2017-10-24 17:53
Reporterrusty 
PriorityimmediateSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version4.1 
Target Version4.1.19Fixed in Version4.1.19 
Summary0014472: MM crashes while ripping (when accessing MP3 files being ripped via My Computer node)
DescriptionThere have been a couple of reports that MM 4.1.19.1854 crashes while ripping tracks:
http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=88674
ZZR-377-95154
Steps To Reproduce1. Rip cd (right click on cd and select "rip audio cd")
2. While cd is busy ripping go to "my computer node"
3. Go to where you told mm to save your rips (in my case it is C:\"User"\Music\CD Rips)
4. Continually press F5 again and again until the crash occurs
TagsNo tags attached.
Fixed in build1856

Relationships

related to 0014466 closedmichal MM Crashing on playback (regression) 
related to 0014487 closedmichal MP3 file may be deleted by tagging when locked (with the new id3lib) 

Activities

Ludek

2017-10-19 16:18

developer   ~0048997

Last edited: 2017-10-19 16:19

View 2 revisions

I can reproduce using steps from the forum http://www.mediamonkey.com/forum/viewtopic.php?f=6&t=88674

It isn't a regression, it crashes in 4.1.16 too.

Ludek

2017-10-20 10:52

developer   ~0049011

The improved steps to reproduce (that leads to the crash almost always) are:

1. Rip cd (right click on cd and select "rip audio cd")
2. While cd is busy ripping go to "my computer node"
3. Go to where you told mm to save your rips (in my case it is C:\"User"\Music\CD Rips)
4. Continually press F5 again and again until the crash occurs

Fixed in 4.1.19.1856 and merged to 5.0.0.2082

Ludek

2017-10-20 12:23

developer   ~0049013

Testing further the crash was really regression related to new id3lib.dll compilation. It crashes in 4.1.16 because we had invalid id3lib.dll. It doesn't crash in 4.1.17 where we had the original id3lib.dll again (compiled using MSVC6) and starting from 4.1.18 it crashes again (with the new id3lib compiled by new compiler). This is most probably also related to the crash 0014466

peke

2017-10-22 00:16

developer   ~0049020

Verified 1856